Driver detection/loading issue with ASUS SDRW-08D1S-U external optical drive

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

tsaka

Thread Starter
Joined
Nov 24, 2009
Messages
3
I am having difficulty with my ASUS SDRW-08D1S-U external optical drive. My computer is an ASUS UL30A notebook with Windows 7. The strange thing is that it was working initially, but now a few days later, it stopped working for some reason. If I go to My Computer, I can see my harddrives (C and D) listed, but not my optical drive. If I go to Control Panel, and click on Devices and Printers, I see my optical drive listed under Devices as SDRW-08D1S-U, with a small yellow triangle icon with an exclamation point on it. If I double click on it, and then click on the Hardware tab, it states at the bottom – “Device Status: Windows cannot load the device driver for this hardware. The driver may be corrupted or missing.” If I click on the Properties button, it basically says the same thing, with the addition of: (Code 39). I have tried updating the driver, and it states that I have the appropriate and latest driver. I have tried disabling and enabling driver. I have tried right clicking on the icon and Troubleshooting.

Finally, I tried uninstalling the driver. And then when I plugged the drive back in, it states that the “Device driver software was not successfully installed.”

I am using the supplied USB Y cable with both ends plugged in. I have tried it also with only one of the two ends plugged in, and also with regular non-Y configuration USB cables.

I will add that I never installed the original software on the CD that came with the drive. I was about to install it when I found that it decided to quit cooperating. But it doesn’t make sense that it was working initially (I installed Microsoft Office on CDs using the drive) and now has stopped working for no apparent reason. Any help would be greatly appreciated!!
 

tsaka

Thread Starter
Joined
Nov 24, 2009
Messages
3
No replies yet...I guess there is no easy fix for this... I'll probably put up the drive for sale and get something else...
 
Joined
Nov 11, 2009
Messages
38
It could be that windows 7 installed there own drivers for your external that were wrong. Don't download any optional driver downloads from windows update and try to reinstall the original driver software from the manufacturers of the external drive, could try there website instead of using the CD, same issue could effect the CD drive if that's why it's not cooperating.
I hope this helps
 

tsaka

Thread Starter
Joined
Nov 24, 2009
Messages
3
maniczombie, thanks for your suggestion, that sounds like a good explanation for what is going on. I tried to uninstall the windows driver for the optical drive, basically by clicking the uninstall button while in the device manager, but somehow it wasn't really doing anything I think. Anyway, you have given me some encouragement, so I'll see what I can do to work on the driver issue. Thanks again!
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top