Drop-down menus blocked by pop-up blocker

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

dentltek

Thread Starter
Joined
Oct 9, 2007
Messages
3
I can't figure this one out...it only happens when I'm using IE, not Firefox (I know, the solution to my problem would be to not use IE, but it still bugs me that I can't figure out what's going on...). The problem is only with my home computer (IE7, Win XP Pro) not my computer at work or anywhere else, and they are all set up the same...

When I come to a web page that has a drop-down menu (as an example, go to the FAQ page, the kind of menu under "Matching Options" and "Search In"...) the menu gets blocked as a pop-up, with the pop-up alert bar at the top of the page. Before instructing me on how to "disable" the IE pop-up blocker, this happens whether the pop-up blocker is enabled or not. If I click on the pop-up information bar, one of the options is to "Turn ON pop-up blocker" if it is off, or "Turn OFF pop-up blocker" if it is on, either way it still blocks the menu from dropping down.

I have tried adding the sites to my allowed sites list. I have tried resetting IE settings. I have tried searching online for other people with the same problem, but all I get is an endless list of sites explaining how to disable the IE pop-up blocker.

Any suggestions??

Kevin
 
Joined
Dec 31, 2007
Messages
611
The instructions here may help

The input dialog boxes blocker security feature is designed help protect your security online, as these input dialog boxes are often used to spoof input fields on legitimate websites. So it’s blocked regardless of general Pop-up Blocker settings. However, you can allow input dialog boxes generated by scripting from specific websites, by adeding the sites into your Trusted Sites zone in Internet Explorer 7. To do this:

1. Go to Tools in Internet Explorer 7, then click on Internet Options.
2. Go to Security tab.
3. Select the Trusted sites zone.
4. Click on Sites on launch the panel to manage trusted sites.
5. Key in the specific site that you want to trust and allow all pop-ups including script-generated input dialog boxes to the text box for “Add this site to the zone”. If you’re viewing the website that you want to trust, the URL link location will be shown automatically.
6. Click Add when done. Note that if the website is not encryted with SSL, you need to unclick (unselect) “Require server verification (https:) for all sites in this zone” before you can Add the normal http: websites.
7. The website should listed on the middle box Website listing.
8. Click Close and then OK to exit.

The website will now no longer be blocked any elements, be it normal webpage pop-ups or dialog boxes. You may need to restart the browser for the new setting to take effect
 

dentltek

Thread Starter
Joined
Oct 9, 2007
Messages
3
Thanks Techychick, that was the first thing I tried but it does nothing. When I found that "fix" earlier a couple of things occurred to me: 1) if I was experiencing a normal security feature with IE7, everyone else would be having the same problem; 2) I should not have to disable the pop-up block feature, meaning I am now allowing all popups, just to get the drop-downs to work, and i should not have to go through all that,and then restart IE just to get it to work correctly; and 3) all of my other computers, and I bet yours as well, allow the drop-down menus to function without having to add that particular site to the allowed site list.

I'm thinking it has something to do with how my IE is processing the html or java scripts, but i know nothing about all that, or about why this particular computer would do this and my others don't.

Any more ideas??
 
Joined
Dec 31, 2007
Messages
611
Has IE7 always had this behavior? And yes, you are right in that I don't have the same issue nor have I ever.
Have your tried resetting all of the security options to default, and/or a reset of IE settings?

Possibly a reinstall of IE may be a solution....
 

dentltek

Thread Starter
Joined
Oct 9, 2007
Messages
3
Yes, I have tried resetting everything to default, still nothing.

But here's something that makes me want to just give up on figuring it out anyways: I just installed the Avant browser, I had read some good things about it. I also heard that the structure of the program is based on IE. The first thing I did after installing was go to a page with a drop down menu and... it is doing the same thing IE does, same pop-up info bar at the top of the window, blocks drop-downs whether pop-up blocker is on or off, etc.

Like I said, I use Firefox on a regular basis anyways so this is not a big deal if I never figure it out, I just don't like not being able to fix something :)
 
Joined
Dec 31, 2007
Messages
611
I just don't like not being able to fix something
Completely understand, I'm the same =)

But, as I stated before an uninstall/reinstall of IE may fix this annoyance, nothing to lose anyway
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top