dual booting into RH7.2 using Win2k boot loader doesn't work (3 SCSI drives)

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

hemlock

Thread Starter
Joined
Aug 29, 2002
Messages
9
I have an adaptec 2940UW, 2 wide Cheetah drives & 1 narrow (Connor) - all SCSI.
I had Win95 running on Cheetah1(ID14). I had previously attempted to install Win2k on
what I'll call Cheetah2(ID0), partition1, dual booting with RH Linux on other partitions on
Cheetah2.

That was not very successful on several accounts, so I proceeded to reinstall both
operating systems on a freshly repartitioned Cheetah2(ID0).

After (re)installation of Windows 2000 Professional on Cheetah2(ID0), I began looking for
the Ntldr, Ntdetect.com, Ntbootdd.sys, Boot.ini etc.
It was NOT on the Cheetah2 drive. Finally I discovered it on the Connor drive (ID2). During
the Win2k boot there is an option screen of what to boot - Win2k pro or Windows, if I
select win2k pro, everything proceeds normally & the OS boots from Cheetah2; but if I
select windows, I end up on the Connor (ID2) & windows(95) starts but cannot complete.
From there I can access Cheetah1, but not Cheetah2. The failure to boot win95 doesn't
bother me - I have working Win95 on Cheetah1, which I can boot by altering the boot
drive in the 2940 BIOS.

The problem is that in trying to alter the boot.ini & boot into RH linux, I run into problems
that I believe are related to Ntldr, Ntdetect.com, Ntbootdd.sys, Boot.ini etc. being on the
WRONG drive.

here's my boot.ini:
[boot loader]
timeout=10
default=signature(98ed98ed)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
signature(98ed98ed)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Professional" /fastdetect
multi(0)disk(0)rdisk(0)partition(2)="Red Hat 7.2 p2 no slash"
multi(0)disk(0)rdisk(0)partition(2)/boot="Red Hat 7.2 p2 /boot"
multi(0)disk(0)rdisk(0)partition(2)\="Red Hat 7.2 p2 \ "
multi(0)disk(0)rdisk(0)partition(2)\boot="Red Hat 7.2 p2\boot"
multi(0)disk(0)rdisk(0)partition(5)\boot="Red Hat 7.2 p5 \boot"
multi(0)disk(0)rdisk(0)partition(5)\="Red Hat 7.2 p5 \ "
C:\bootsect.lnx="Linux via bootsect.lnx"
C:\ = "Microsoft Windows"

In the installation of Red Hat 7.2 I told it to put the boot loader record in the 1st sector
of boot partition. As you can see from above I don't fully comprehend the process & use the
trial & error approach. The next to last line C:\bootsect.lnx="Linux via bootsect.lnx" when
selected for boot gives the following message: "Grub Geom Error".
All the other options either give me some windows error message about booting problem
or reboots my machine.

I assume that somehow Grub looks at the Connor, instead of the Cheetah2 & decides there's
a problem. (there's no \boot partition - it's all one FAT32 part.)
Is that right? How can I get it to go boot from the Cheetah2?

[
Some years in the past the Connor drive was my boot drive (for win95) & I think on my first
attempt at dual booting Win2k & Linux on the Cheetah2, I may have copied Ntldr,... etc to
the Connor as a backup, from where it was (on the Cheetah1 drive!).

Soooo, why in the world did the installation of Win2k put it on the Connor (clearly from latest
installation from the date), instead of on the Cheetah2?
how do I get it back onto the Cheetah2 & get the MBR to find it there?
]
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top