1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Dv7 Laptop Screen turns on but displays nothing

Discussion in 'Hardware' started by MFire2003, Nov 14, 2011.

Thread Status:
Not open for further replies.
  1. MFire2003

    MFire2003 Thread Starter

    Joined:
    Nov 14, 2011
    Messages:
    1
    Hi There,

    I'm new to here but was hoping someone could guide me on what could possibly be the problem with my Laptop. I'll try to include as much information as possible.

    I have a HP DV7-1260US 17" Laptop running Windows 7 64Bit. I took the PC apart to clean out the fan that was really dusty. I disassembled the PC using this guide: http://www.insidemylaptop.com/disassemble-hp-pavilion-dv7-notebook/

    I got to step 14, and stopped. I didn't want to remove the LCD display from the laptop so I just dusted the fan from that step and re-assembled the PC. When re-assembled the PC powers on, the Fan comes on, the Hard Drive light is displayed as if everything is ok. The screen "comes on" in the sense that the backlight turns on but nothing is displayed on the screen. The screen gives a dark-blue tint when it is "on" without a display. I disassembled the PC again to check any connections and noticed that the connector for the Power Cover/Board was broken off. So I ordered a new power cover & board as well as a LCD Video Cable (i didn't have reason to think this was damaged but since it wasn't very expensive I ordered it as well just in case).
    http://www.insidemylaptop.com/images/HP-Pavilion-dv7-display/remove-lcd-screen-inverter-11.jpg
    http://www.insidemylaptop.com/images/HP-Pavilion-dv7/disassemble-notebook-11.jpg

    The parts arrived, I replaced them both very carefully...same problem. Boots up, screen turns on, screen displays nothing.
    I plugged a Monitor to the laptop via VGA and it displays the desktop fine. So the computer boots up and is properly running, the video can be displayed with a external monitor.

    **Update to this issue...I purchased a inverter and replaced it...still having the same issue. Display comes on but just shows a blue hue...everything works fine if i plug in a external monitor.
    This is what I recently replaced:
    http://www.insidemylaptop.com/images/HP-Pavilion-dv7-display/remove-lcd-screen-inverter-07.jpg

    Any ideas on what could have gone wrong or what I should attempt next?
    Any help would be appreciated, thanks!
     
  2. managed

    managed Trusted Advisor Spam Fighter

    Joined:
    May 24, 2003
    Messages:
    13,183
    First Name:
    Allan
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1026906

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice