1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

ECS K7S5A Death

Discussion in 'Hardware' started by asphalt-race, Apr 22, 2004.

Thread Status:
Not open for further replies.
  1. asphalt-race

    asphalt-race Thread Starter

    Joined:
    Apr 21, 2004
    Messages:
    3
    Hello all,
    I have an ECS K7S5A with Athlon XP1800+. System was working fine, until I changed heatsink and fan for cpu. Now system won't post, no video, no beeps. I have reseated video card, memory sticks, rechecked cpu and heatsink to no avail. I also used Antec Formuls 5 thermal compound. I have since replaced motherboard and processor and system works great. Is there any to check if the problem was the cpu or the motherboard?
     
  2. Triple6

    Triple6 Moderator

    Joined:
    Dec 26, 2002
    Messages:
    52,923
    First Name:
    Rob
    You would have to test the suspect parts with known good parts. Testing the CPU would be quite easy, just try it on your new board, if it works then its most likely the motherboard but to be sure you would have to test with the CPU, Video, RAM plugged in.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/223013

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice