Electric Typewriter help!

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Aaminee

Thread Starter
Joined
Jun 5, 2018
Messages
6
hi
I’m new to this thread - I recently bought a Smith Corona 470 for my daughter and somehow the ribbon cassette doesn’t move forward. It keeps typing in the same spot and the ribbon runs out of ink. I even bought new replacement ribbon but still the same issue. I read about an “E” clip somewhere online but it didn’t give any info on how to find/fix it.
I would really appreciate help with fixing this issue!!
Thx in advance
 

ekim68

Mike
Joined
Jul 8, 2003
Messages
58,034
The ribbon is driven by a gear on the plate that the ribbon mounts. If it's not turning it won't drive the ribbon. There are several reasons for this including not having a retainer clip at the bottom of the gear post. Normally you have to pull the carrier out to get to this and it's labor intensive.. Any typewriter techs in your area?
 

Aaminee

Thread Starter
Joined
Jun 5, 2018
Messages
6
Thanks for the reply; not sure of any typewriter techs around here. Do you know if there’s an online resource that can guide me through it?
 

ekim68

Mike
Joined
Jul 8, 2003
Messages
58,034
I'll look around and in the meantime can you post a picture of the Machine to make sure I'm thinking of the same Model?
 

ekim68

Mike
Joined
Jul 8, 2003
Messages
58,034
Good pictures and the one to the right is super. The ribbon drive unit is directly to the right of the hammer and it looks like it's not sticking up high enough to drive the gear in the ribbon. Check and see if there's up and down motion with it and check the base of the Typewriter for a clip that's fallen off. I'll try and find a service schematic, but usually because I'm older, I'm slower... ;)
 

Aaminee

Thread Starter
Joined
Jun 5, 2018
Messages
6
Hi
Upon closer inspection, Ive noticed that the vertical shaft that fits into the cassette, has a prong missing or broken which might be resulting in it not fitting snugly into the cassette, to turn it. Hence the ribbon is not advancing. Any suggestions on what to do>?
 

ekim68

Mike
Joined
Jul 8, 2003
Messages
58,034
It looks like the parts for this machine have been discontinued, as per the link above. Probably the best bet is to try and chase down a used machine that has that part. And maybe it's possible to drill a hole in the shaft and insert a small pin.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top