1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Epson Stylus Photo RX630 multifunction center

Discussion in 'Hardware' started by spacemanben, Jun 2, 2008.

Thread Status:
Not open for further replies.
  1. spacemanben

    spacemanben Thread Starter

    Joined:
    May 7, 2008
    Messages:
    20
    Hi all,
    thanks in advance for any help.
    Got an epson RX630 multifunction centre. Prints great but the scanner is playing up, don't know what to do.
    Havent contacted epson yet but its on my list of things to do.

    Scanner used to work fine but it suddenly stopped working.
    Whenever you scan all you get is a white page regardless of what you scan, and when you photocopy you get a faint image in a verticle stip in the middle of the A4 page but this fades to white before the edges of the page.

    I didn't do it, and i still can't beleive the guy that did it did it, but someone reinstalled windows on the machine without removing it first, and the systems been struggling ever since, the scanner died after this but not immediately.

    Any help would be apreciated,
    spacemanben.
     
  2. OGreatMasterTech

    OGreatMasterTech

    Joined:
    May 25, 2008
    Messages:
    35
    When you scan it is the picture completely white? Or is there little specs in it?
     
  3. arknorth

    arknorth

    Joined:
    Oct 17, 2007
    Messages:
    1,099
    Okay - took a bit of searching - the RX630 wasn't sold over here in the States (We had the RX620 - same machine, different packaging - yay Epson!)

    It is actually possible to restore XP without removing it - and it is possible to do this without loosing all your files, but you do usually have to replace all the periferal drivers, as the Windows that you'll be running will be in a raw state, as if newly started for the first time, because, well... its being started for the first time.

    BUT - XP has nothing to do with making a copy, and what you describe is not good. Have you tried leaving the lid open while doing a copy to see what the scan lamp is doing while it tracks across the page? These newer scanners should actually show little light when doing so, as they use a thin flourecent bulb these days with an over-exposure shield to limit burnouts.

    A scanning test I would run would be if you have a photo-editing program installed in your PC (Photo Shop, Photo-Paint, Illustrator, the lot). To see if it's the scanning program or the scanner itself, I would bring one of these programs up and see if I could directly activate the scanner using the Aquire function most of these have (without using the Epson program directly OR pushing the SCAN button on the console). If the image comes up correctly, then I would say that the Epson SCANSMART software is corrupt. Reinstalling it would fix that problem.

    But its the copy function that's got me worried. That's not a function that requires the computer, and if you're getting results as you describe, that's not good - it could be a failing scan bulb.

    A-N
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/717598

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice