1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Error when printing with win 98: SPOOL32 caused an invalid page fault in

Discussion in 'Earlier Versions of Windows' started by MotoMan, Apr 7, 2005.

Thread Status:
Not open for further replies.
Advertisement
  1. MotoMan

    MotoMan Thread Starter

    Joined:
    Aug 13, 2003
    Messages:
    47
    Here is the error message:

    SPOOL32 caused an invalid page fault in
    module KERNEL32.DLL at 017f:bff7b9a6.
    Registers:
    EAX=00000000 CS=017f EIP=bff7b9a6 EFLGS=00000246
    EBX=82a1f650 SS=0187 ESP=0086fef0 EBP=0086ff10
    ECX=c16aca00 DS=0187 ESI=82a1f8f0 FS=1b87
    EDX=bffc9490 ES=0187 EDI=82a1f848 GS=0000
    Bytes at CS:EIP:
    ff 76 04 e8 13 89 ff ff 5e c2 04 00 56 8b 74 24
    Stack dump:
    82a1f824 7fabc393 82a1f8f0 82a1f824 00000000 82a1f650 82a1f650 00000000 0086ff74 7fab237a 82a1f824 82a1f654 00510b00 82a1f650 7fab228d 82a1f824

    I have fixed this before on other computers here at the office by dowloading a windows ME .dll file and replacing the one on the current machine, but unfortunatly, I seam to have lost the intstructions, and the file to do it with.

    Any help guys??? Please?
     
  2. flavallee

    flavallee Frank Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    63,648
    Is this what you're looking for?

    How to install SPOOLSS.DLL Fix on Windows 98/98 SE:
    FIRST close ALL printing Jobs (if any) AND the print Spooler (SPOOL32.EXE).
    IF SPOOL32.EXE is still running [Ctrl+Alt+Del], download + install CoolKill [797 KB, freeware].
    Run COOLKILL.EXE -> right-click on the CoolKill icon in Taskbar Tray -> highlight SPOOL32.EXE -> left-click on it to terminate this process.
    Download + install SPOOLME.EXE.
    Restart Windows.

    If it is, you can access the SPOOLME.EXE download by going to this site, scrolling down to the Windows 98/98 SE + DOS 7 header, clicking the 98SE Updates link, then scrolling down to the Microsoft Windows 98/98 SE SPOOLSS.DLL build 4.90.3000 Fix from Windows ME - 90 KB, English link.
     
  3. MotoMan

    MotoMan Thread Starter

    Joined:
    Aug 13, 2003
    Messages:
    47
    Yep, that was it bro!!

    Thanks a ton man, I couldn't find that anywhere. (y)
     
  4. flavallee

    flavallee Frank Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    63,648
    You're welcome. :)

    I'm not familiar with CoolKill or what it does, but I don't see why the Windows ME 4.90.3000 version of SPOOLSS.DLL just can't be installed over the Windows 98SE 4.10.2223 version without running CoolKill first. :confused:
     
  5. Bob Cerelli

    Bob Cerelli

    Joined:
    Nov 2, 2002
    Messages:
    22,468
  6. flavallee

    flavallee Frank Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    63,648
    Thanks, Bob. :)

    I get most of my Windows 98SE updates and hotfixes from the AXCEL site and currently have version 4.10.2223 of SPOOLSS.DLL installed. (y)
     
  7. Bob Cerelli

    Bob Cerelli

    Joined:
    Nov 2, 2002
    Messages:
    22,468
    flavallee,

    Is there a reason you previously suggested using "Microsoft Windows 98/98 SE SPOOLSS.DLL build 4.90.3000 Fix from Windows ME" instead?

    That's the main reason I posted the link to a newer version.
     
  8. flavallee

    flavallee Frank Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    63,648
    Bob:

    I didn't recommend it. He was looking for it and I knew it was posted in the AXCEL site.

    The KB250514 SPOOLSS.DLL 4.10.2223 update that you posted a link to is the one that I currently have installed and which I obtained from the AXCEL site. I haven't installed the 4.90.3000 version of it - unless you think I should.
     
  9. Bob Cerelli

    Bob Cerelli

    Joined:
    Nov 2, 2002
    Messages:
    22,468
    Guess from this and no mention of the newer version it was a bit unclear.
     
  10. flavallee

    flavallee Frank Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    63,648
    Do you recommend sticking with the 4.10.2223 version or getting the 4.90.3000 version of SPOOLSS.DLL?
     
  11. Bob Cerelli

    Bob Cerelli

    Joined:
    Nov 2, 2002
    Messages:
    22,468
    If the latest version is working I'm not sure why you would want to change.
     
  12. flavallee

    flavallee Frank Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    63,648
    I value your advice, so I was just asking. I'll stick with 4.10.2223 for now.
     
  13. Bob Cerelli

    Bob Cerelli

    Joined:
    Nov 2, 2002
    Messages:
    22,468
    Actually the confusion came mostly since there was that very first reply mentioning an earlier version where you mentioned:

    "Microsoft Windows 98/98 SE SPOOLSS.DLL build 4.90.3000 Fix from Windows ME" and then a few posts later the newer version.

    If you check back, none of my posts ever recommended using the earlier version at all.
     
  14. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/350582