Solved Excel Behaviour

Status
This thread has been Locked and is not open to further replies. The original thread starter may use the Report button to request it be reopened but anyone else with a similar issue should start a New Thread. Watch our Welcome Guide to learn how to use this site.

Tabvla

Thread Starter
Joined
Apr 10, 2006
Messages
2,643
System : Lenovo PC W10 with all updates

I must have clicked on some setting because Excel is exhibiting unusual behaviour.

If I have 2 spreadsheets open they are both active, the one behind the other, on the screen at the same time. If I click on SS_1 it comes to the front, if I click on SS_2, then it comes to the front. But they cannot both be viewed at the same time. This means that I cannot split the screen and have the two spreadsheets side-by-side, they only display one behind the other.

That is not normal behaviour.

Any suggestions as to how to fix this would be most welcome.

T.
 

etaf

Wayne
Moderator
Joined
Oct 2, 2003
Messages
65,501
have a look at
>Window
>Arrange

Thats what i have done in past to see spreadsheets on screen organised
 

Couriant

James
Moderator
Joined
Mar 26, 2002
Messages
42,542
Actually that is normal behavior. I suspect as etaf has mentioned you may have had it set to some kind of arrangement.

I assume you have the latest Microsoft Office?
 

Tabvla

Thread Starter
Joined
Apr 10, 2006
Messages
2,643
Thanks Wayne and James for your replies.

I don't think that I am explaining the problem correctly..... so let me try again.

On my other computer, if I open two Excel spreadsheets, each spreadsheet behaves as an independent entity. I can view either spreadsheet or both simultaneously, if I use the Windows split screen function (not the Excel split screen function). If I move one, the other stays where it is. If I minimise one the other stays maximised.

On this computer, two Excel spreadsheets don't behave as independent entities. If I minimise one, the other also minimisers, if I move one to the left (or right), the other moves in tandem, behind the first one. I cannot use the Windows split screen function to view two spreadsheets side-by-side.

Yes, I agree I can view both spreadsheets in various ways if I use the Excel "View" functions. But then Excel wraps both spreadsheets in a wrapper, meaning that both spreadsheets are contained within the same Excel frame.

That isn't what I want. I want the spreadsheets on this computer to behave in the same way as on my other computer, namely as separate entities, independent from each other and not wrapped in the same frame.

It is not that easy to explain, but I hope that the above makes more sense than my first Post.

T.
 

etaf

Wayne
Moderator
Joined
Oct 2, 2003
Messages
65,501
i think i understand, but not seen 2 windows linked together like that before , and haven't found anything on google bout spreadsheet windows linked together and move together.
 

Tabvla

Thread Starter
Joined
Apr 10, 2006
Messages
2,643
Thanks Wayne. And that is not how it used to work. So, I can only conclude that I have done something (dumb) by changing a setting, somewhere, sometime to induce this strange behaviour.

T.
 

etaf

Wayne
Moderator
Joined
Oct 2, 2003
Messages
65,501
quite possibly a Key combination accidently hit together. I have a particular Forum, where any emails are automatically set to read , and i cant fix that , but it happened after i picked the laptop up and touched a few keys...
 

Tabvla

Thread Starter
Joined
Apr 10, 2006
Messages
2,643
You might be correct. I have looked through all the Excel View settings and there is nothing there that makes me think that I have inadvertently changed something.

If I cannot fix this I will just have to use the Excel options.

Thanks for your help.

T.
 

Couriant

James
Moderator
Joined
Mar 26, 2002
Messages
42,542
OK I see what you are saying now. Have you tried looking under Multitasking settings on both machines to make sure they match? That's the only thing I can see at this time that fits your description.

Windows key + arrow key performs a snap, etaf may be onto something there :)
 

Keebellah

Hans
Trusted Advisor
Joined
Mar 27, 2008
Messages
6,833
I'm not sure but could it be a sync setting?
Have you checked that both spreadsheets are NOT set to sync?
If on the other system Excel only minimizes the active spreadsheet it could mean that there are two instances of Excel running which would explain the fact that Windows split screen works and not arrange windows inside Excel because that doesn't work on two Excel instances.
:unsure:
 
Joined
Dec 29, 2020
Messages
1,812
Open excel open file.
Open excel again open file.
You have to open excel twice. Otherwise it will view one over the other as you now have.
 

Tabvla

Thread Starter
Joined
Apr 10, 2006
Messages
2,643
Open excel open file.
Open excel again open file.
You have to open excel twice. Otherwise it will view one over the other as you now have.
Well.... I learnt something today.... Excel can sometimes be just a little more weird than expected.

I have the Excel Icon on the Task Bar. If I right-click on it a pop-up menu shows the spreadsheets that I normally use on a daily basis. I select the one I want to work on. Usually I need to work on more than one simultaneously, so I repeat the above right-click action and select another spreadsheet. Both spreadsheets show in the Task Bar as individual entities. But as Peter has posted, they are not, they are one instance of Excel (displaying the behaviour that I previously described), even though they show on the Task Bar as separate entities. That is just a little weird.

Therefore if instead of the above procedure, I follow Peter's advice, and open Excel and then from the File Menu open the first spreadsheet I want to work on and then open Excel again and from the File Menu open the second spreadsheet, I then have two separate entities of Excel and the spreadsheets now behave in the manner that I expect them to behave and can be manipulated via Windows.

That almost negates the whole idea of a Shortcut if one still has to go the long way round if one wants to work on two spreadsheets simultaneously. (NY to LA via Miami).

However, this only seems to apply to Excel if it is a local program installed on the computer. I also use Microsoft 365 (previously called Office 365), and in the Cloud version Excel does not show this rather bizarre behaviour.

In conclusion..... thanks to Wayne, James, Hans and Peter for your invaluable help. Much appreciated..(y)(y)

T.
 

Johnny b

John
Joined
Nov 6, 2016
Messages
9,868
Good morning, T

I've been using an older version of Excel from Office 2000.
The issue of only having one instance of Excel on the desktop bugged me a lot.
I installed LibreOffice which allows multiple instances without any extra manipulation.
Whether opening spreadsheets one at a time or multiple files all at once, the result is the same as shown in the image below.

Calc.jpg

I don't know if that helps you, but it works well for me.
 
Status
This thread has been Locked and is not open to further replies. The original thread starter may use the Report button to request it be reopened but anyone else with a similar issue should start a New Thread. Watch our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Top