external cd-rw/dvd-r not being picked up.

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

dconway01

Thread Starter
Joined
Jan 9, 2006
Messages
8
I have a compaq evo with winxp2 and I have purchaed an external combo dvd-r/cd-rw (usb 2.0) drive. I connected it to my usb connection and it picks up the usb connection but then it says there is a problem installing the new hardware and it is not picked up as a removeable device. Also there is an exclamation mark under usb section in device manager where the external device should reside:eek: . When i restarted the pc all the prgrams did not load and there was only a view of the desktop so I disconnected the drive from the pc and it worked fine- any ideas - please help.
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,722
Create a file with NOTEPAD containing the following lines and save it as FIX.REG
-------------------------- cut after this line --------------------------------
REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment]

"DEVMGR_SHOW_NONPRESENT_DEVICES"="1"
-------------------------- cut before this line --------------------------------

Double click on FIX.REG and say yes to the Merge Into Registry question.

Unplug ALL USB devices.
Open Device Manager.
View, Show Hidden Devices.
Uninstall all devices under USB Controllers.
Uninstall all devices under Disk Drives that you know are not present.
Uninstall all devices under Storage Volumes. Say no to any reboot prompts until you are finished. Also, if a Storage Volume doesn't uninstall, ignore it and move to the next one.
If you have a yellow ? with unknown devices, uninstall all of the entries there as well.

When this is done, reboot TWICE.

Reconnect the USB devices and see if they're recognized properly.
 

dconway01

Thread Starter
Joined
Jan 9, 2006
Messages
8
Thanks for that JOhnWill but I tried that and I am still getting the same error. It however say that this device could operate faster if I had a 2.0 controller- how do I find out what version of usb I have and could this be the problem?
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,722
It should still be recognized, however you won't be able to record and DVD's on a USB 1.1 connection. What is the specific error you have where you see the yellow !
 

dconway01

Thread Starter
Joined
Jan 9, 2006
Messages
8
HI, yes it says Usb mass storage device and there is a yellow exclamation mark next to it.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top