1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

External Hard Disk not being detected...

Discussion in 'Hardware' started by FelterX, Nov 7, 2011.

Thread Status:
Not open for further replies.
  1. FelterX

    FelterX Thread Starter

    Joined:
    Oct 12, 2011
    Messages:
    8
    I brought a Seagate Expansion Hard Disk about six months ago and have never had problem with it till now....
    The problem is that my HD does not get detected if its plugged in after the windows startup.... In most cases it hangs my PC. The green light blinks so I'm positive that it's not a problem of the HD. The safely remove hardware icon also comes up. But the Autoplay menu doesn't show up and its icon wont be there in My Computer (that is, if I'm able to open My Computer. As I already stated, in most cases, the PC gets stuck).
    I discovered that there are no issues if I keep it plugged in the USB port before the startup, but that is an inconvenience since I only have one free port :(. Ive tested with other pen drives and they work just fine. I even tried plugging it to a different port, but to no avail. It would really nice if you could help me with this....
    Thnx in advance.....
     
  2. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    Try it on another machine. It sounds like the drive is having some problem. Run chkdsk /r on it in the other machine and check for bad sectors.

    Hopefully, the data was backed up recently. External drives are the most unreliable of all storage media. If not, you better make a fresh backup in case something is wrong with the drive.
     
  3. FelterX

    FelterX Thread Starter

    Joined:
    Oct 12, 2011
    Messages:
    8
    Sorry for replying so late.
    Anyways, I tried it out on my friends pc and the external hdd was working...Was quite relieved to find out it wasn't my external hdds problem. I got used to connecting my hard disk before turning on my PC. But today, at last, I found out what the problem was. Seems it was an issue of my AV software(Eset Smart Security v. 5). Now who would've thought of that!!!???
    Eset has now released an update fixing this issue... Here's the link:-
    http://kb.eset.com/esetkb/index?page=content&id=SOLN2854
    Just thought I'd post this here in case someone is having these same problems...

    Thanks for your help anyways, Elvandil. Really appreciate it.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1025810

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice