1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

External hard drive no longer recognized

Discussion in 'Hardware' started by beadesigner, Oct 23, 2017.

Thread Status:
Not open for further replies.
  1. beadesigner

    beadesigner Thread Starter

    Joined:
    Jun 16, 2017
    Messages:
    1
    A few nights ago I was backing up data from my old Vista laptop onto an external hard drive. I've had this particular setup since '15.

    The problem started when the laptop's power pack fell from a higher shelf down to a lower shelf on the desk, about 2 feet in distance or less. It's nowhere near the external drive and is even plugged into a different surge suppressor, but the power pack falling caused the backup to fail. The external hard drive was no longer showing as connected, though it was still accessible. The power pack was still connected to the laptop; this laptop is so old (ca 2008) the battery died a very long time ago, so if the power pack was disconnected from the computer, the computer would have gone out immediately. It was still running fine after the incident and is right this minute, after being on for at least 20 hours since (though not consecutive hours), and probably longer. When the power pack fell the connection didn't even loosen.

    As for the external drive, I could see everything on it, even open whatever folders I wanted, but in trying to copy files over, I received an error, "The disk is write-protected. Remove the write-protection or use another disk." The options were "Try Again," "Skip" and "Cancel."

    I was also unable to delete any files from the external drive. The "Delete" command didn't appear on the menu and pressing the delete key after highlighting files did nothing.

    I tried rebooting the computer, but the same thing happened, as it did after shutting down the entire computer and restarting. Though when I turn on the external drive it does show as a device that's accessible to the laptop, files can be viewed (and the external drive disconnects properly from the laptop when commanded), there's still no copying, no deleting of files. I'm still getting the "write-protected" error.

    I then tested a newer computer (Windows 10) with the external drive. No problems. It works exactly as it always has. The problem is exclusively with the Vista laptop.

    Why would a power pack that's unrelated to the external drive cause backups to permanently stop working? Is there a fix to get them working again? I have no other way of making backups on this particular computer.

    Thanks in advance!
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1198292

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice