1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

external hard drive not recognized in Vista

Discussion in 'Hardware' started by thumpmeister, Jan 5, 2009.

Thread Status:
Not open for further replies.
Advertisement
  1. thumpmeister

    thumpmeister Thread Starter

    Joined:
    Jan 5, 2009
    Messages:
    5
    Recently I restored my computer to the factory default, because of software hangups, and not being able to remove games that I had bought, loaded, etc. Vista would not allow some games to be removed. So, I decided to reload the computer as it came from the factory. PRIOR to, I did a backup of all my pictures on a WD 1200 bb external hard drive. The drive worked great and the pictures were there. Then I deleted them from my computer hard drive along with a lot of other old files. Now, restored, the computer recognizes the external drive in CMOS and in the device manager and shows it to be working properly and has the latest driver. But when going into Computer, the drive is not shown. It shows my hard drive, C & D, (1 hard drive but shown as C & D and the card reader drives (removable)and the DVD drive, but no external drive. In disk Management, the drive is shown as Disk 1, basic, and online but when right clicking on it the little window does not give me the right to change drive letter or path. No matter what I do, I cannot access this external drive. The disk shows power is on and it seems to be spinning. Anyone's help would be greatly appreciated.
     
  2. thumpmeister

    thumpmeister Thread Starter

    Joined:
    Jan 5, 2009
    Messages:
    5
  3. bigbear

    bigbear

    Joined:
    Apr 27, 2004
    Messages:
    4,719
    Have you tried the external drive on another machine?
    Was the external drive connected to the pc when you did a clean install of Vista?
     
  4. thumpmeister

    thumpmeister Thread Starter

    Joined:
    Jan 5, 2009
    Messages:
    5
    Thanks for your response! Yes, I tried the external drive to another computer, a laptop running xp, same thing occurs, drive recognized in device manager but is not shown in computer. Yes I do believe the drive was hooked up when I did the reinstall.
     
  5. bigbear

    bigbear

    Joined:
    Apr 27, 2004
    Messages:
    4,719
    That fact it does the same on another machine leads me to suspect the controller in the external case maybe starting to fail.
    There is no real way of telling other than removing the drive from the case and hooking it up as a slave in another machine.
    If you can then access the drive ok then its the case at fault, if not then its the drive
     
  6. thumpmeister

    thumpmeister Thread Starter

    Joined:
    Jan 5, 2009
    Messages:
    5
    I ran a Western Digital Retrospect program and it passed. I will run the full scan (2 hrs 20 min) long and check it again.
     
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/787111

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice