External HDD permissions broken

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

ForgotPants

Thread Starter
Joined
Jan 21, 2013
Messages
1
I have a WD MyPassport 1TB external drive that I used for almost a year on my Windows 7 machine at home, work and a few other computers and it worked fine.

I recently upgraded to Windows 8 on my home machine and the HDD was working fine between my home and work computers, my office machine is still Win 7. I visited my dad and plugged my drive in on his Windows 7 PC and thats when the problem started, my hard drive wouldnt detect and gave an Access Denied error. The only thing I could do was Take Ownership. So I took ownership and the drive worked again with some permission fixes. After I came back home and plugged the drive in, it gave me the same Access Denied error.

Ever since then, my hard drive only works on one computer at a time. Everytime I plug it anywhere else, I can only access it after taking ownership. What did I do wrong? How can I fix this?
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top