External HDD/Vista

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

jlaing91

Thread Starter
Joined
Mar 30, 2008
Messages
3
Hi,

I've just bought the Sum-vision 35USL External HDD Enclosure and fitted it with a 500Gb IDE. I'm running Windows Vista Home Premium and I can't seem to get it to recognise the drive. It's connected via USB 2.0. Any help would be much appreciated.

Jlaing91
 

Triple6

Rob
Moderator
Joined
Dec 26, 2002
Messages
52,933
You may just need to partition and format the drive, which needs to be done before it can be used.

To do so, right click on Computer and select Manage. Then go to the Disk Management section and select the new drive, you then may need to initialize, partition, and format it.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top