External HDMI display detected by PC, but no signal

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

attila_the_lol

Thread Starter
Joined
Dec 27, 2014
Messages
3
Hi! Please help!

This was working fine before I had to format my computer. I'm about six hours deep in this — it's killing me. I'll provide you with any info I can, but I'm far from knowledgeable about this kind of thing.

The problem:
My second display is recognized by my computer, but it receives no signal, showing a blank screen with no sound.

My setup:
Windows 7 64bit. I have a monitor as a main display and a TV connected as an extended display. The monitor is connected via DVI. The TV is connected via HDMI. The TV is a PDP-R04. My graphics card is an AMD Radeon R9 270X using the latest drivers (14.501.1003.0). The cable works — tested on other devices with the same TV. The TV works. The source settings on the TV are correct.

Things I've tried:
- rolling back to previous display drivers
- uninstalling display drivers in safe mode and re-updating
- resetting CMOS to defaults
- booting computer with only the TV plugged in
- changing the TV's resolution settings
- crying
 
Joined
May 12, 2011
Messages
7,933
First Name
Jim
Has the second screen been configured? It should show up in the Display panel, at which point you have to select "extend desktop to this display" and apply the settings.
 
Joined
Jun 27, 2014
Messages
20,216
First Name
Liz
I had to format my computer.
Did you install all the drivers for your hardware? If the hdmi is part of the motherboard, you need to be sure all the chipset drivers are installed.
 

attila_the_lol

Thread Starter
Joined
Dec 27, 2014
Messages
3
Has the second screen been configured? It should show up in the Display panel, at which point you have to select "extend desktop to this display" and apply the settings.
The second screen does show up in the Display panel. I can change any settings on it from my computer, and when I set it to an extended display, it lets me drag objects to and interact with the new space, but still displays nothing.


Did you install all the drivers for your hardware? If the hdmi is part of the motherboard, you need to be sure all the chipset drivers are installed.
The HDMI goes to my video card. Just to be safe, I went through and updated as many motherboard drivers as I could find just now, but the display is still down. My board is a 955A-UD6(C).
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top