1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Fans and lights start up. No POST...again

Discussion in 'Hardware' started by Inglonias, Dec 24, 2010.

Thread Status:
Not open for further replies.
  1. Inglonias

    Inglonias Thread Starter

    Joined:
    Nov 13, 2009
    Messages:
    82
    This problem relates to the first computer in my specs list.

    Okay, so my computer is now about two years old. Occasionally, the computer will fail to POST, but lights and fans will start up. Unfortunately, I had this problem before. It was due to a faulty power supply, and since I have a modular version of that same unit (Raidmax RX-700, yes I know. I know it sucks.) I'm betting its the culprit again. Nevertheless, I just wanted to be sure before this problem got any worse.

    Guys and gals: Is it my power supply? AGAIN?
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/970406

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice