Solved File History errors - unable to restore from external HD

kbtechhelp

Thread Starter
Joined
Mar 19, 2014
Messages
54
Hi,

Apologies in advance if there is already a post for this.

I recently had my laptop repaired so I backed up my files via File History to an external hard drive. I am now trying to restore these files from the backup however, it does not seem to like the hard drive.

1) File History is turned on but when I go to restore files it says "No file history not found. File history is currently turned off"

2) When I go to reselect the drive, it says "We found errors in your File History settings.". Event Viewer shows the following:

Unable to start a backup cycle for configuration C:\Users\k_bhu\AppData\Local\Microsoft\Windows\FileHistory\Configuration\Config

I have attached screenshots of the above errors.

Grateful if somebody could advise.
 

Attachments

Goddess-Bastet

Virginia
Joined
Apr 26, 2019
Messages
930
Ensure that File History was set up correctly after you received the repaired PC:
See Glen Gailey’s reply here:
https://answers.microsoft.com/en-us...-4a61-bffc-7e8578ffc285&page=5&tab=AllReplies
The answer is still good for Windows 10.

He states:
I just had to try to do this, and I was able to (on a new Win8 machine) point at the previous backup by clicking Drives and then selecting my backup drive (a network share in my case). Then I was able to check "I want to use a previous backup on this File History drive" and it displayed my existing backups on that drive. Finally, I was able to do the regular (if not very intuitive) restore files by clicking the settings icon in the upper right of File History.

More in-depth tutorial here:
https://www.techrepublic.com/articl...-data-files-to-a-new-windows-10-installation/

I hope this helps.
 

kbtechhelp

Thread Starter
Joined
Mar 19, 2014
Messages
54
Hi there,

Thanks for your reply. Unfortunately, I don't seem to have the checkbox option for "I want to use a previous backup on this File History drive" - see screenshots attached.

Is there something I am missing or need to enable for this to show?
 

Attachments

Goddess-Bastet

Virginia
Joined
Apr 26, 2019
Messages
930
That may be due to the backup drive already being in use & registered as the backup drive..
I would choose to stop using the drive then follow the steps again.
 

kbtechhelp

Thread Starter
Joined
Mar 19, 2014
Messages
54
That still didn't work.. I've removed it, unplugged it then plugged it back in, added it again and still that option doesn't show.. assuming i have explored all options.
 

Attachments

kbtechhelp

Thread Starter
Joined
Mar 19, 2014
Messages
54
Okay - this can now be resolved. I carried out a Windows Update and seemed to fix it. Thanks for your help anyway.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top