File transfer extremely slow

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

mconnelly

Thread Starter
Joined
Dec 23, 2011
Messages
140
So, I'm trying to transfer files from my old PC to this new build. I moved all files to an external Toshiba 320GB hard drive. It's a single folder of 220Gb. So far I haven't seen the transfer speed go faster than 1.7Mbs. The screenshot below shows the details. I started this process yesterday at about 4 pm EST. It's now 11:30 am, the next day, and the progress is shown in the screenshot. I still have over a day left to get this finished. Granted it is an older external hard drive (Toshiba 593400-E) but I would have thought it would take a lot less time to move the files. This transfer is also slowing my PC down to a speed that only rivals a old 486. Please help!

File Transfer.png

Tech Support Guy System Info Utility version 1.0.0.4
OS Version: Microsoft Windows 10 Pro, 64 bit
Processor: Intel(R) Celeron(R) G4900 CPU @ 3.10GHz, Intel64 Family 6 Model 158 Stepping 11
Processor Count: 2
RAM: 4029 Mb
Graphics Card: NVIDIA GeForce GT 710, 1024 Mb
Hard Drives: C: 465 GB (410 GB Free); E: 465 GB (368 GB Free); G: 298 GB (76 GB Free);
Motherboard: ASRock, H310CM-DVS
Antivirus: Windows Defender, Enabled and Updated
 
Last edited:

Macboatmaster

Trusted Advisor
Spam Fighter
Joined
Jan 14, 2010
Messages
24,102
I suspect the problem may be - the location of where you are copying them to
I can see from the screenshot it is
Media

Please develop on that and explain where the copy to location is
Also what type of files are these - 220GB is a rather large amount of data
Are they all only personal data of one manner or another
 

texasbullet

Ramon
Joined
Jun 11, 2014
Messages
2,771
Maybe you have too many videos in your drive. Try moving one document at a time. It is time consuming but is more likely for less crashes during the process.
 

mconnelly

Thread Starter
Joined
Dec 23, 2011
Messages
140
I suspect the problem may be - the location of where you are copying them to
I can see from the screenshot it is
Media

Please develop on that and explain where the copy to location is
Also what type of files are these - 220GB is a rather large amount of data
Are they all only personal data of one manner or another

They are being transferred to the E: drive. It's a secondary HDD that I installed to store video. The entire folder is all video.

I think I'm just going to start over. Delete all transfers that have completed so far and redo it 1 file at a time so the files operate properly once the transfer is done.
 

Macboatmaster

Trusted Advisor
Spam Fighter
Joined
Jan 14, 2010
Messages
24,102
On a slightly differing note
Your system would run a lot better with more ram
Your board
Dual Channel DDR4 Memory Technology
- 2 x DDR4 DIMM Slots
- Supports DDR4 2666 / 2400 / 2133 non-ECC, un-buffered memory
Max. capacity of system memory: 64GB*
I am not of course suggesting 64
but 8 instead of 4 would make a tremendous difference
especially if the 4 is one stick

You are on the minimum with 4

Is there any chance you can put the drive in the SATA port in the computer you have 4 ports - the transfer would be a lot quicker
 
Joined
Sep 21, 2007
Messages
12,432
Before you start moving the files, go to This PC > Properties > Advanced system settings > Performance Settings button > adjust for best performance. This setting sets all the pretty graphics effects of Windows to off and will result in better performance.

Then when you are copying the files, start Task Manager, go to details tab, find 'explorer' and right click, set Priority to High.
 

Macboatmaster

Trusted Advisor
Spam Fighter
Joined
Jan 14, 2010
Messages
24,102
You may also find that speed is slightly improved if you go to
Windows defaults USB drives to use a “Quick removal” data transfer policy. This disables write caching, which slows down transfer speeds, but lets you disconnect a device safely without using the “Safely Remove Hardware” prompt.
GO Device Manager, and open it. Expand the Disk Drives tree and locate the USB drive you’d like to improve (it must be plugged in to the PC). Double-click the drive’s icon and, in the window that appears, find the Policies tab. Click the “Better performance” radio button and then, underneath, check the “Enable write caching on the device” checkbox (some devices don’t support this, however). Then click OK.

lunerlander
Good point re Best Performance - especially if it makes a difference.
Did not think of it.
 

mconnelly

Thread Starter
Joined
Dec 23, 2011
Messages
140
On a slightly differing note
Your system would run a lot better with more ram
Your board
Dual Channel DDR4 Memory Technology
- 2 x DDR4 DIMM Slots
- Supports DDR4 2666 / 2400 / 2133 non-ECC, un-buffered memory
Max. capacity of system memory: 64GB*
I am not of course suggesting 64
but 8 instead of 4 would make a tremendous difference
especially if the 4 is one stick

You are on the minimum with 4

Is there any chance you can put the drive in the SATA port in the computer you have 4 ports - the transfer would be a lot quicker

The RAM is in the mail. Just waiting for it. The drive is only the USB connection so I don't have the ability to hook it up to SATA.
Incidentally, I deleted the files that had transferred up to the last time we spoke. I tried doing it 1 file at a time and it was no different. The first file was only 500 Mb and it took a half an hour. I guess i have to wait for the RAM to come in the mail. I'm also going to try the other items that were suggested in the post. Wish me luck.
 

mconnelly

Thread Starter
Joined
Dec 23, 2011
Messages
140
You may also find that speed is slightly improved if you go to
Windows defaults USB drives to use a “Quick removal” data transfer policy. This disables write caching, which slows down transfer speeds, but lets you disconnect a device safely without using the “Safely Remove Hardware” prompt.
GO Device Manager, and open it. Expand the Disk Drives tree and locate the USB drive you’d like to improve (it must be plugged in to the PC). Double-click the drive’s icon and, in the window that appears, find the Policies tab. Click the “Better performance” radio button and then, underneath, check the “Enable write caching on the device” checkbox (some devices don’t support this, however). Then click OK.

lunerlander
Good point re Best Performance - especially if it makes a difference.
Did not think of it.

So, I set the USB device to "Better Performance". Cross your fingers please!
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top