1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Firefox "Back button" doesn't work

Discussion in 'Web & Email' started by Cardinalduke, Apr 5, 2009.

Thread Status:
Not open for further replies.
Advertisement
  1. Cardinalduke

    Cardinalduke Thread Starter

    Joined:
    Aug 27, 2006
    Messages:
    7
    Lately, when I use "Alt + left arrow" or the back setting on my logitech MX revolution mouse, firefox doesn't seem to recognize my keystroke/click.

    Instead, I have to click the blue back button on the top left of my screen.

    What course of action do you suggest I do to correct this? Thanks in advance,

    -Cardinal
     
  2. AKAJohnDoe

    AKAJohnDoe

    Joined:
    Jun 5, 2007
    Messages:
    1,320
  3. Cardinalduke

    Cardinalduke Thread Starter

    Joined:
    Aug 27, 2006
    Messages:
    7
    Thank you for the link. It is actually the keyboard shortcut and the mouse click (I set three or four buttons on my mouse to 'back' and none work) that is not working for me. I can do a left mouse click on the web browser and it will take me back.

    Sometimes when I click one of my 'back' buttons on the mouse, it actually just highlights the file menu. No clue why.
     
  4. AKAJohnDoe

    AKAJohnDoe

    Joined:
    Jun 5, 2007
    Messages:
    1,320
    Somewhere in either the documentation for your mouse or perhaps the control panel for it could there be a mapping of the codes sent?
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/816018

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice