1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Firefox focus issues

Discussion in 'All Other Software' started by 8BitKronik, Apr 25, 2012.

Thread Status:
Not open for further replies.
Advertisement
  1. 8BitKronik

    8BitKronik Thread Starter

    Joined:
    Mar 4, 2009
    Messages:
    52
    So, I've gone to Mozilla and even a nifty little website about this unique issue I'm having with Firefox.

    It is irritating, no infuriating..just plain annoying..Firefox always seems to auto focus on search bars. I do not always want the browser to focus onto a search bar for every single page I am on and I most certainly do not want it to continue to focus on the search bar. No. Matter. What. I. Do.

    I use key bindings. I find it a hassle to click around pages to navigate them when I can do it in half the amount of time by pressing a key. I would like to choose whether or not I want to focus on the search bar. I am always grateful for answers and support. However. If your answer resembles any of the links posted above I am not interested. I am obviously asking for assistance here because I need a different answer from the run of the mill ones I have been having. Thanks.
     
  2. jessi_mac03

    jessi_mac03

    Joined:
    Apr 26, 2012
    Messages:
    3
    which version of firefox do you have?
     
  3. 8BitKronik

    8BitKronik Thread Starter

    Joined:
    Mar 4, 2009
    Messages:
    52
  4. Ent

    Ent Josiah Trusted Advisor

    Joined:
    Apr 11, 2009
    Messages:
    5,408
    Could you suggest a few of the sites which cause this problem?
     
  5. Ent

    Ent Josiah Trusted Advisor

    Joined:
    Apr 11, 2009
    Messages:
    5,408
  6. 8BitKronik

    8BitKronik Thread Starter

    Joined:
    Mar 4, 2009
    Messages:
    52
    I have tried the solution with user.js/prefs.js it however it does not work. If there was however a way to modify it into the about:config that might work. I tried your first solution which actually gave me hope however it did not work.

    My main issues are with google. (I know there's google instant but isn't that javascript?) And the Mozilla webpage. Most webpages with search engines do the thing I have described previously. The reason however the .js files do not work is because everytime Firefox is started or re-started they are overwritten. I even put write-protection and it didn't work. I think for the values to be recognized they have to be modified in about:config.
     
  7. Ent

    Ent Josiah Trusted Advisor

    Joined:
    Apr 11, 2009
    Messages:
    5,408
    I think that google uses javascript to focus, not conventional autofocussing features. You could try disabling javascript to see whether the issue stops.
     
  8. 8BitKronik

    8BitKronik Thread Starter

    Joined:
    Mar 4, 2009
    Messages:
    52
    Wouldn't that make other webpages unstable or seem not complete?
     
  9. Ent

    Ent Josiah Trusted Advisor

    Joined:
    Apr 11, 2009
    Messages:
    5,408
    Yes, it would.
    I'd suggest you try that though, because if it solves the immediate problem we can look at a more precise response. Obviously turn the JS back on afterwards.
     
  10. 8BitKronik

    8BitKronik Thread Starter

    Joined:
    Mar 4, 2009
    Messages:
    52
    Ah. I finally get what you're saying. If it was an issue with Javascript then scripting the problem away would work. I updated my java console/add-on. I then disabled them and the problem persists.
     
  11. Ent

    Ent Josiah Trusted Advisor

    Joined:
    Apr 11, 2009
    Messages:
    5,408
    What do you mean by disabled the "java console/add-on"? Java is as distinct from Javascript as Latin is from French. To disable Javascript in Firefox follow the following instructions:

    Open Firefox (duh)
    Press Alt
    Click Tools
    Click Options
    Click Content (in the list of tabs across the top)
    Click on the checkbox by "Enable Javascript"
    Click OK.

    To undo it, merely repeat the process.
     
  12. throoper

    throoper Trusted Advisor

    Joined:
    Jan 20, 2007
    Messages:
    5,152
    It is scripts that target the focus.
    Give this extension a try. It was primarily for SeaMonkey but works well on all versions of FF I've tried it on.
    https://addons.mozilla.org/en-US/seamonkey/addon/yesscript/

    It will allow you to turn off the ability of selected sites to run any scripts with the benefit of having a button to toggle them back on. It's the only thing I've found that will reliably stop the Google Auto suggest and the annoying Search as you type functions.
     
  13. Ent

    Ent Josiah Trusted Advisor

    Joined:
    Apr 11, 2009
    Messages:
    5,408
    No-Script also works, blocking all scripts and requires that you explicitly allow them on a host-by-host basis.
    Does your extension let to distinguish between different scripts from the same host?
     
  14. throoper

    throoper Trusted Advisor

    Joined:
    Jan 20, 2007
    Messages:
    5,152
    It works almost the opposite of NoScript, which blocks all sites unless specifically allowed.
    YesScript allows all sites unless they are added to the list to block.
    It blocks ALL scripts from any site on the list, but it can be quickly toggled to allow scripts to run on that site.
     
  15. 8BitKronik

    8BitKronik Thread Starter

    Joined:
    Mar 4, 2009
    Messages:
    52
    Alright Ent. I did as you said and the problem disappeared.
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1050835