Firefox Has Hijacked Default Browser Designation

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

coover

Thread Starter
Joined
Jan 10, 2003
Messages
116
I upgraded Firefox to v.3.03. Firefox is a nice browser, but it is not my prefered browser, but I like to keep it to take a look at it's ad-ons. I realize that many of you will not understand, but I prefer IE (I'm using v.8 beta 2 at present).

So imagine my shock when everytime I opened IE, I got an error message telling me it was not the default browser and asking if I would like to make it so, Clicking on yes, I figured that was all I had to do. It wasn't. Firefox would not give up the default designation, no matter what I did.

I clicked on the Default Programs tab.There, I set IE as the default browser. There, I set IE as the default for virtuallly all internet extensions. None of this worked, Firefox wouldn't let go. A minor problem, but a pain in the bottom!

I open Firefox and go to Tools > Options > Advanced and find that Firefox is the default browser, but there appears no way to reverse this.

The only option, it appears, is to remove Firefox from the computer. Is there a better way? Perhaps there is a registry edit?
 
Joined
Oct 26, 2001
Messages
57,793
I don't have Firefox 3 but look at the options, Main tab.
You should see "Always check to see if Firefox is the default browser on startup".
Uncheck it.
Then go to IE tools or Internet Properties, Program tab.
Click the "Make Default" and you can uncheck the box there to check too that way you should have IE as your default but be able to open IE or Firefox with getting bugged about it asking you anything about making the browser the default browser from either one.
 

coover

Thread Starter
Joined
Jan 10, 2003
Messages
116
Thank you for your reply.

That was the first thing I checked even prior to writing in about this problem. The checkbox is not checked. The problem is elsewhere.
 
Joined
Oct 26, 2001
Messages
57,793
OK then check the box. Maybe checking it even if you want it checked will undo what ever. But close down IE and Firefox after making the changes. Then change it back the way you want it to be and hope it fixes a bug.
 

coover

Thread Starter
Joined
Jan 10, 2003
Messages
116
Again, thanks. Good idea, Didn't work. Firefox still default.
 
Joined
Jun 5, 2007
Messages
1,320
Sounds to me like IE8 surrendered.

Serously, try telling Firefox it is not the default and tell IE8 it is the default. This could easily be a bug in the beta of IE8.
 
Joined
Oct 26, 2001
Messages
57,793
Not sure but on XP maybe you need to be in the Admin account to make the changes and make it stay. I don't think you do but try it.
 

coover

Thread Starter
Joined
Jan 10, 2003
Messages
116
Thanks, guys and girls.

I've tried all of that, nothing worked so I simply deleted Firefox. I'll try it again next time they have an update.
 
Joined
Jun 5, 2007
Messages
1,320
I still think it is IE8 causing the problem, not Firefox. IE8 is a beta after all, more than the usual number of errors and bugs should be expected. I would expect that the problem would also "go away" if IE V8 were uninstalled and Firefox V3.0.3 and IE V7 were co-installed.
 
Joined
Mar 17, 2005
Messages
1,894
its definately IE8 problem - I have IE7 and FF3 and I can set default browser without any hitches
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top