1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved Firefox running super slow...

Discussion in 'Web & Email' started by dogluver, Jan 27, 2020.

Thread Status:
Not open for further replies.
Advertisement
  1. dogluver

    dogluver Thread Starter

    Joined:
    Aug 4, 2012
    Messages:
    237
    For the past few days, Firefox has been beyond SLOW! I kept getting a message that a script or web page was slowing down my browser...do you want to wait or stop it. I don't know anything about drivers (I read that might be something to look into). Any ideas on what to do? I'm not very computer literate, but would greatly appreciate your help.

    Tech Support Guy System Info Utility version 1.0.0.9
    OS Version: Microsoft Windows 10 Home, 64 bit, Build 18362, Installed 20190826023123.000000-300
    Processor: Intel(R) Core(TM) i5-4200U CPU @ 1.60GHz, Intel64 Family 6 Model 69 Stepping 1, CPU Count: 4
    Total Physical RAM: 6 GB
    Graphics Card: Intel(R) HD Graphics Family, 1024 MB
    Hard Drives: C: 684 GB (602 GB Free);
    Motherboard: Dell Inc. 02TKW1, ver A00, s/n 9P8QQZ1.CN1296641R001D.
    System: Dell Inc., ver DELL - 1, s/n 9P8QQZ1
    Antivirus: Norton Security Suite, Enabled and Updated
     
  2. Couriant

    Couriant Trusted Advisor Spam Fighter

    Joined:
    Mar 26, 2002
    Messages:
    34,944
    First Name:
    James
    Try running Firefox in Safe Mode and see if that helps.

    If it does, then that means you have an addon/extension that is affecting the browser.
     
  3. dogluver

    dogluver Thread Starter

    Joined:
    Aug 4, 2012
    Messages:
    237
    I've been using it for a few hours in safe mode and it is working great. Now, how do I get it out of safe mode? Thanks for your help!
     
  4. Couriant

    Couriant Trusted Advisor Spam Fighter

    Joined:
    Mar 26, 2002
    Messages:
    34,944
    First Name:
    James
    Just close FireFox and restart Firefox without pressing anything else.

    So first I would suggest checking your Extensions:

    Disable all extensions
    To determine whether a faulty extension is causing your problem, you can disable all of your installed extensions:

    1. Click the menu button [​IMG] , click [​IMG] Add-ons and select Extensions.
    2. For any extension listed as Enabled, click the ellipsis (3-dot) icon and select Disable.
      The extension will be moved to the Disabled list.
    3. Repeat this for each of the other extensions.
    4. When all extensions are disabled, close Firefox:
      Click the Firefox menu [​IMG] and select Exit.

    5. Start Firefox the way you normally do.
    When you restart Firefox, all extensions will be disabled.

    Test for your problem. If the problem no longer occurs with all extensions disabled, one of your extensions was causing it. To find the extension that was causing your problem, continue as follows:

    Test for faulty extensions
    To determine which of your disabled extensions was causing your problem, you can re-enable each extension one at a time.

    1. Click the menu button [​IMG] , click [​IMG] Add-ons and select Extensions.
    2. Click the ellipsis (3-dot) icon and select Enable to enable the extension.
    3. Close Firefox:
      Click the Firefox menu [​IMG] and select Exit.

    4. Start Firefox the way you normally do.
    After you restart Firefox, test for your problem. If the problem comes back, the extension you just enabled was causing it.
     
  5. dogluver

    dogluver Thread Starter

    Joined:
    Aug 4, 2012
    Messages:
    237
    Thank you so much. All is good!
     
  6. Cookiegal

    Cookiegal Administrator Malware Specialist Coordinator

    Joined:
    Aug 27, 2003
    Messages:
    115,815
    First Name:
    Karen
    Could you please share with us which extension was the culprit?
     
  7. dogluver

    dogluver Thread Starter

    Joined:
    Aug 4, 2012
    Messages:
    237
    I'm so sorry, I'm not sure. I had mostly shopping ones (wikibuy, Honey, Emoji cheatsheet for GitHub). So I disabled and deleted them. I kept privacy badger and Rakuten formerly Ebates. I didn't know how to figure out which one was causing the problem. I'm sorry! I'm so clueless when trying to fix computer problems. I did the restart and haven't seen that message. I wish I could tell you more. Thanks again for all your advice. **You're dog is so cute, not sure if it's your dog though.
     
  8. Cookiegal

    Cookiegal Administrator Malware Specialist Coordinator

    Joined:
    Aug 27, 2003
    Messages:
    115,815
    First Name:
    Karen
    No problem. In the future if you have the asme issue once you see things are fine with no add-ons or plug-ins then you enable one at a time then close the browser and reopen it then wait a while to see if the problem happens again. If not you can enable a second one and so on.

    From one dog lover to another, thanks for your kind comment about my dog Brandy. :)
     
  9. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1239334

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice