Firefox shortcut icon association

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

provobis

Thread Starter
Joined
Sep 5, 2005
Messages
53
This "icon" problem has not been solved by some pretty good brains I have already tried elsewhere. I thought to try here, after a long absense from Tech Support Guy forums.

If I want to save a web page on my desktop for future reference I drag the little round thingy in the left of the address bar to my desktop where a Firefox icon is placed. Then of course if I point my mouse on that FF icon it gives me the address of that page and if I double click on that icon it takes me to that page again.

The icon always placed was the FF icon (an orange fox wrapped around the earth within a rectangular white box). Lately however, what has been placed is a IE document icon instead of the FF fox/world icon. I have been advised that this glitch is probably not malware but no one has found a solution, and someone has suggested that FF has done this intentionally with a upgrade that now uses the IE shortcut icon instead of the FF one. I don't think that's very likely.

Many fixes have been tried including uninstalling and reinstalling FF, icon association change fixes, etc.

Anyone?
 

provobis

Thread Starter
Joined
Sep 5, 2005
Messages
53
Have you tried this ?
At the top of the Firefox window, click on the Firefox button (Tools menu in Windows XP) and then click Options, Select the Advanced panel, click the General tab, and then click "Make Firefox the default browser"
If this doesn't help see this Setting Firefox as the default browser does not work - What to do.
Thanks bkmgy, but FF has always been my default browser, and when I check as you indicate (even though in my general tab it actually tells me that FF is already my default browser). Yesterday I tried doing a XP repair (twice) thinking that Windows was somehow the problem, because from everything I researched so far the icon that's placed as a shortcut is found by windows in the icon cache. But when I look to see if there is actually an icon cache, there isn't on this HD, but I know there should be because on a spare HD that's not being used at the time it is. So if there's no icon cache you can't delete it using the "rebuild" procedure. That's why I tried a XP repair.

But when I did the repair (twice) it hangs at the end of the installation. So the repair is incomplete, I'm guessing that there's something corrupted in XP on this HD that it can't repair itself. I had to shut down the repair at that point and even though I can boot up that incomplete HD the shortcuts don't work and some of my settings are bananas. So it looks like I will have to reinstall XP, and start over. Agree?
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top