Flight Sim X Deluxe

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

pc_doctor

Thread Starter
Joined
Jan 22, 2005
Messages
484
Hi everyone,

Got a new graphics card the other day.

Spec is as follows:
Operating System: Windows Vista™ Ultimate 64 Bit
Mobo: P5W DH Deluxe
Processor: Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz (2 CPUs), ~2.4GHz
Memory: 4094MB RAM
Graphics Card: NVIDIA GeForce 8800 GTS 640MB
HDD 1 Seagate 500GB Sata 11
HDD 2 Western Digital 80GB Sata


I have played BF2 and Fear, but i am having issues with Microsoft Flight Simulator X Deluxe.

I have installed SP1 for it, but its lagging alot in game - FPS is 8-10 or so, and thats with settings like Medium High etc

Any suggestions or tweaks? As i dont feel im getting that good graphics.
 
Joined
Nov 15, 2005
Messages
6,118
That's one big computer you've got yourself there.... :)


As for the lag, no idea where that's coming from. It's obviously not hardware. ;)

Try emailing microsoft support if nobody else replies to your thread. :)
 
Joined
May 23, 2007
Messages
73
WOW, my specs are WAY lower than yours, and I'm getting better frame rates on medium high than you are!!! Weird... Are you sure that FSX can be played on the 64 bit version of Vista? might wanna check that out...
 

pc_doctor

Thread Starter
Joined
Jan 22, 2005
Messages
484
Yep its meant to support Vista - as i said i have no issues with BF2 or anything.

Its really annoying though - I thought the game was going to be good.
 
Joined
Aug 1, 2002
Messages
5,531
PC Doc,

Are you by chance running many apps in the background while trying F/ Sim ?

If so then try closing down A. Virus and other progs not necessary while playing this game.

As observed, your system spec is very high, so possibly something running in the background is making demands on your system.

==========

You might also read the boards at these aviation related forums too in case you can glean some information from them.

http://www.flightsim.com/

http://www.avsim.com/

http://forums.avsim.net/

These people also bring out numerous mods, skins, and other addons you can download to enhance your game once you get it going.
 

pc_doctor

Thread Starter
Joined
Jan 22, 2005
Messages
484
I'm running AVG Anti-virus and often or not i have MSN Open.

To be honest that wouldn't hinder the FPS would it???

Personally i think its a Direct X 10 issue.
 

pc_doctor

Thread Starter
Joined
Jan 22, 2005
Messages
484
Your all going to laugh at this i get a maximium of 10 on LOW well Minimal Settings in Flight Sim - How crap is that!!!
 

pc_doctor

Thread Starter
Joined
Jan 22, 2005
Messages
484
Im using onboard sound - i dont think this could hinder my Frame Rates.

I recon its a Direct X 10 Issue and NVidea hasnt make proper drivers for it....i can only guess its a matter of waiting.
 
Joined
Aug 28, 2007
Messages
2
To answer your question yes it could be your sound card.
I was having all kinds of problems with FSX downloaded and updated my video driver etc.
My issue was I was running at 25-30 FPS and FSX would freeze at certain points and I couldn't figure it out. So I went back to verify that all my drivers were updated and low and behold my sound card driver was showing Aug 2001. So I downloaded the last good driver (which I have the SB Live) which was in Feb 2003 and all my problem stopped and I was able to increase my sliders etc. So it would be worth it to check all your drivers under Control Panel/System/Device Manage. Hope that helps.
 
Joined
Aug 14, 2007
Messages
46
Wow I wouldn't have thought that sound drivers would have affected things so much.. But using onboard sound would affect things even more than outdated sound drivers for a card, I guess. I'm a little puzzled how a computer with such high-end components got so shanked in the sound department. Sound cards are cheap, even the good ones!

I have a very mid-range setup, but with SP1 installed, I get very comfortable frame rates, even over urban settings. Most of my options are set medium-high, and 20-25 fps is the norm. Before SP1, I was getting single-digits unless I was over Antarctica or something. :)
 
Joined
Nov 15, 2005
Messages
6,118
Nice Arclight!! I have updated my onboard sound card drivers and it has seemed to have made a big difference.

Thanks for your wonderful TIP. :)
 
Joined
Aug 14, 2007
Messages
46
So what are your frame rates like now? I'm curious because it really is a lovely setup you've put together. Let me live vicariously through you! :)
 
Joined
Aug 28, 2007
Messages
2
Since upgrading my sound drivers (I did the others about a month ago) I get 30+ FPS.
Something to keep in mind, if you are getting 20+ FPS thats is as much as the human eye can differentiate to real time. In other words, your eyes can't tell the difference. If it drops below 20 FPS then you start seeing the hesitations. My specs are a Pentium D 3 gig, 2 gigs RAM,Nvidia 7600gs 512 meg, WinXP Pro.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top