framerate issues with Napoleon Total War

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

dudnaito

Thread Starter
Joined
Mar 5, 2010
Messages
8
I can play just about every game i've tried. Bad Company 2, Batman, Prototype, Dragon Age Origins, Bioshock 2, etc... but Napoleon Total War, which according to Can You Run It, i should be able to kill is giving me massive framerate problems.

I have a 512 mb ATI Radeon 4570

Windows 7 Home Premium

You Have: 2.53 GHz Performance Rated at: 3.795 GHz

Recommended: 2 GB RAM (XP), 4 GB RAM (Vista®/Windows® 7)
You Have: 4.0 GB

Its a brand new laptop too, so i have an excess of 400 gb lying around too.

Is this a normal issue?

Strange thing is, i also have this problem with the Witcher, but it seems like some people have framerate problems with the Witcher when they have monster desktops. Mine is just a laptop btw. Thanks a lot. Any help is greatly appreciated. I love the total war series.
 
Joined
Apr 4, 2010
Messages
12
I can play just about every game i've tried. Bad Company 2, Batman, Prototype, Dragon Age Origins, Bioshock 2, etc... but Napoleon Total War, which according to Can You Run It, i should be able to kill is giving me massive framerate problems.

I have a 512 mb ATI Radeon 4570

Windows 7 Home Premium

You Have: 2.53 GHz Performance Rated at: 3.795 GHz

Recommended: 2 GB RAM (XP), 4 GB RAM (Vista®/Windows® 7)
You Have: 4.0 GB

Its a brand new laptop too, so i have an excess of 400 gb lying around too.

Is this a normal issue?

Strange thing is, i also have this problem with the Witcher, but it seems like some people have framerate problems with the Witcher when they have monster desktops. Mine is just a laptop btw. Thanks a lot. Any help is greatly appreciated. I love the total war series.

What settings are you using ingame RES? AA ? AF ?
 

dudnaito

Thread Starter
Joined
Mar 5, 2010
Messages
8
i even tried putting witcher in all low, no grasses, etc.... it doesn:t matter; not even noticeable improvement in framerate. I tried googling and other people with even monster desktops seem to have the same problem with the witcher specifically. even after patch updates.
 
Joined
Apr 4, 2010
Messages
12
In regards to witcher it does indeed sound like a buggy release but i dont own it so cant be sure . But For Boney:TW i only hit Frame rate issues with that when i ramp up the AF to 16x i run it at 1680 x 1050 with 8x AA 8xAF with no major Frame rate issues on my 5770 except for when it pans the map right at the start of a new SP game. try knocking the shader model down to 2 and using just 2x AA and 2x AF and make sure ATI console isnt overriding the ingame settings.

Also as a side note, make sure you have your laptop running off the mains when your gaming so that powersaving isnt been used. obvious i know but just thought id mention it
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top