Fresh install freeze up laggy poor performance

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Manapulti

Thread Starter
Joined
May 1, 2019
Messages
1
Hey everyone. I have a custom built pc i bought from someone and i installed win 7 myself and for some reason its taking forever to do anything. Gets stuck opening chrome. Pages go slow. Ive updates all drivers using and windows updates. Updated java. Direct x. And i check task manager and its using a ton of ram. I did hard drive tests. Cpu gpu memory tests and no issues. Internet speedtest i get 100mbps windows rating was 4.8 but its laggy and slow and acting like its having issues doing what it needs to do. I honestly tried everything i can do and no luck any advice? Ill pay someone to remotely fix it for like 10 bucks lol
 
Joined
Mar 30, 2014
Messages
4,188
Download, install and run Speccy. Click File > Publish Snapshot > Yes > Copy to Clipboard and then paste in the URL you just copied into a Reply to this thread.
 
Joined
Jan 7, 2014
Messages
2,650
Did you install the chipset drivers and all the other drivers from the motherboards website?
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top