1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Front USB Ports Not Always Working

Discussion in 'Hardware' started by blahraptors, Apr 10, 2008.

Thread Status:
Not open for further replies.
  1. blahraptors

    blahraptors Thread Starter

    Joined:
    Apr 9, 2008
    Messages:
    4
    Hello!

    I have a Gigabyte motherboard in a Antec Lanboy case. The case has two front USB ports. The USB ports do not work with most devices. For example if I plug in a USB key or a webcam I get the balloon that says "the device may not be recognized". But if I plug in a keyboard, mouse, or RF receiver, it works. Could it be that the front ports are USB 1.1 or are underpowered? I've read that Gigabyte USB connections are a bit different, but I've checked them before and are as illustrated in the manual :confused: By the way, I'm on XP SP2 and the USB connections from the mobo are not a single block - they are individual pins.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/702406

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice