1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

FTP and Router

Discussion in 'Networking' started by Ztrain, Sep 19, 2003.

Thread Status:
Not open for further replies.
Advertisement
  1. Ztrain

    Ztrain Thread Starter

    Joined:
    Jun 6, 2002
    Messages:
    20
    I currently have set up a Linksys router so I can get wireless internet in my house. However, I also run an ftp off my machine, no copyrighted material, just religious materials. When I try to access it from outside my internal network, it can not be found. My friend recommended that I need port mapping or the like to open a port to access it. What should I do? Any input would be appreciated. Thanks.
     
  2. roban

    roban

    Joined:
    Jul 9, 2002
    Messages:
    394
    you have to go to your router setup page. This is a webpage usually accessed by opening your browser and putting 192.168.0.1 in the address box. You might have to put an http:// before it. Your router manual can tell you. Once in the setup you have to go to the page where you setup ports. For a server you usually setuo what's called a "virtual server" on port 21. You have to activate this port and reboot the router.
     
  3. Mithrilhall

    Mithrilhall

    Joined:
    Mar 28, 2001
    Messages:
    781
    Actually for a Linksys router you will probably connect to it using a web browser like Internet Explorer. The address should be http://192.168.1.1 if it still has the factory settings.

    Once you connect to the router click the advanced tab and then click the Port Forwarding tab. Now you'll have to forward port 21 to your computers IP addresss.

    Now I would recommend turning off DHCP in the router and hard coding an IP address for each computer connected to the router (something like IP address: 192.168.1.2 Subnet Mask: 255.255.255.0 Gateway 192.168.1.1 DNS numbers you might have to get from the cable company or you can click Start-->Run-->cmd then run ipconfig /all and that should give you your DNS numbers.

    So write down the DNS numbers and the subnet mask and the IP address. Now, on your desktop right-click Network Neighborhood and Choose properties. Right-click Local Area Connection and choose properties. Select TCP/IP (don't uncheck the box) and click properties. This is where you'll plug those numbers in.

    When you make the changes to your router you don't have to reboot it. Just click the apply button. All should work if I didn't leave anything out.

    On a side note, many ISPs block incoming port 21 requests so their subscribers can't run FTP Servers. You can simply change the port your FTP Server is running on if this is the case. There should be a setting on the FTP Server to do this.

    Another good thing to have so you don't have to remember you IP address when accessing your FTP Server is http://www.no-ip.com

    Instead of accessing your FTP Server via ftp://102.142.10.9:(port number if you changed it) - you can access it using ftp://A_Name_You'll_Remember

    I'm not sure if that last part made sense but if you head on over to http://www.no-ip.com you'll be able to read up on it.
     
  4. Akito

    Akito

    Joined:
    May 23, 2003
    Messages:
    931
  5. Ztrain

    Ztrain Thread Starter

    Joined:
    Jun 6, 2002
    Messages:
    20
    When I try set up www.no-ip.org to see my machine, it sees the router address only allowing it to only connect to the router not to the internal network behind it. And to my knowledge I did not see a way on the no-ip.org free registration to selection what port to connect on nor a means to illustrate the fact that it is an ftp server.
     
  6. Squashman

    Squashman Trusted Advisor

    Joined:
    Apr 4, 2003
    Messages:
    19,783
    The only thing NO-IP needs is what your IP address is on the wan side of your router. It doesn't matter that it is an FTP server. Your router takes care of the port forwarding to your machine on your lan.
     
  7. Mithrilhall

    Mithrilhall

    Joined:
    Mar 28, 2001
    Messages:
    781
    Make sure you install the No-IP software and set it up correctly.


    If you go to "Manage" on www.no-ip.com you should see something similar to this. Now, to get to my webserver (which runs on port 8000 since my ISP blocks port 80) I would use the following address: http://mithrilhall.no-ip.com:8000

    Since it isn't really nice looking to give out your address:IPAddress I used the redirect service, hense the http://mithrilhall.redirectme.net

    The redirect allowed me to append a port number after the URL as you can see from the example. Now when I give out my URL I can give http://mithrilhall.redirectme.net instead of http://mithrilhall.no-ip.com:8000

    Now, in the router you would have to Forward port 8000 to the appropriate IP address (example: 192.168.1.3). You will also have to make sure your webserver is running on the correct port (In my case it's 8000).


    Hosts / Redirects
    ----------------------

    No-IP Free Domains
    Host: IP / URL Action:
    ------------------------- --------------------------- -------------------
    no-ip.com

    mithrilhall.no-ip.com 166.125.24.22 [IP] Modify | Delete


    redirectme.net

    mithrilhall.redirectme.net mithrilhall.no-ip.com:8000 Modify |Delete
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/165995

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice