1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Funny dots on my screen?

Discussion in 'Hardware' started by Haggisinlondon, Jan 15, 2002.

Thread Status:
Not open for further replies.
Advertisement
  1. Haggisinlondon

    Haggisinlondon Thread Starter

    Joined:
    Jan 11, 2002
    Messages:
    5
    I have a GEforce 2 Pro 64MB card in my machine. It has been running well for since I got it about 4 months ago. lately however I notice specs on the screen come and go and also some degredation of the graphics. If I refresh the screen it clears but slowly comes back? I thought maybe it was the drivers for my graphics card, but then noticed that when the machine powrs up and shows the device screen, before the operating system even starts loading there is sometimes a red cell or some coloured block on the screen.

    I reseated my graphics card and checked the fan is running?

    Any ideas on the cause? or solution?

    thanks
    haggis
     
  2. brianF

    brianF

    Joined:
    Dec 2, 1999
    Messages:
    12,041
    Try some different version drivers. If you don't have them you can find them here

    http://www.reactorcritical.com/download.shtml

    Could be heat related or it could be the card's memory is going bad. Probably drivers though.
     
  3. richardp

    richardp

    Joined:
    Jan 11, 2002
    Messages:
    98
    How old is your monitor? and how old was the graphics card before you put it in? This does not seem to be a software error but a hardware error.
     
  4. Haggisinlondon

    Haggisinlondon Thread Starter

    Joined:
    Jan 11, 2002
    Messages:
    5
    The card and monitor were brand new. They are about 4 months only. They are a LG Flatron screen and a Leadtek geforce 2 pro 64mb card.
     
  5. Brooks

    Brooks Guest

    Joined:
    Oct 30, 2001
    Messages:
    2,323
    Do you have access to a different monitor? Try it. Also, try that monitor in a different computer. This sounds like the monitor might have some circuitry going bad. Flat Panels can display symptoms similar to card problems, but the problems are in the monitor.

    The spots sound like the lcd's are loosing thier charge slowly over time, but once you refresh, they are recieving a new charge and are returning to normal for a time. This is not normal.

    I would contact LG and talk with thier tech support. Since it is only 4 months old, it should still be under warranty.

    http://www.lge.com
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/64973

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice