Games lag on laptop

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

royyyy

Thread Starter
Joined
Nov 7, 2011
Messages
5
Hello i'm new here

I have troubles with my Acer Aspire 5553G laptop.

When i try to play games like runescape and darkeden i get ALOT of lag but when i first bought this laptop it ran all fine.
Surprisingly i don't lag alot when playing Counterstrike-Source.
I recently cleaned up the inside of my laptop with compressed air and then tried the games again but they still lag alot! I even resetted system to factory settings, but no luck.

Please help me!!

EDIT: specifications--

processor:
AMD Phenom II N930
Caspian 45nm Technology

ram:
4,00 GB Dual-Channel DDR3 @ 532MHz (7-7-7-20)

graphics card:
ATI Mobility Radeon HD 4250 (Acer Incorporated [ALI])
ATI Mobility Radeon HD 5650 (Acer Incorporated [ALI])

hdd:
625GB TOSHIBA TOSHIBA MK6465GSX ATA Device (SATA)
 

Tanis

Shane
Joined
May 29, 2006
Messages
4,101
Hi and welcome to TSG.

Why do you have two graphics cards listed? I have done a bit of a search and as far as I can tell the 5553G came with either a HD5650 or an HD5470, from that I would assume yours is the 5650 flavour?

Source: http://support.acer.com/acerpanam/notebook/2010/Acer/Aspire/Aspire5553G/Aspire5553Gsp2.shtml

When you reinstalled, did you do a total reformat and did you update all your software and drivers afterwards? If yes, did you get the drivers from the Acer website or from somewhere else?
 

royyyy

Thread Starter
Joined
Nov 7, 2011
Messages
5
Hi and welcome to TSG.

Why do you have two graphics cards listed? I have done a bit of a search and as far as I can tell the 5553G came with either a HD5650 or an HD5470, from that I would assume yours is the 5650 flavour?

Source: http://support.acer.com/acerpanam/notebook/2010/Acer/Aspire/Aspire5553G/Aspire5553Gsp2.shtml

When you reinstalled, did you do a total reformat and did you update all your software and drivers afterwards? If yes, did you get the drivers from the Acer website or from somewhere else?
The reset only reinstalled windows 7 back on C drive. I haven't updated drivers yet.
 

Tanis

Shane
Joined
May 29, 2006
Messages
4,101
If you haven't got all the drivers and sofware updated yet then I would start there, as that could be at least part of the lag problem. It is always good practice to start diagnosing a problem when all software etc. is all up to date and patched :)
 

royyyy

Thread Starter
Joined
Nov 7, 2011
Messages
5
Hello

I have installed the graphics drivers for my laptop and the speed increased a little bit but it still lags on runescape highest graphics mode while it shouldn't.

What would i have to do next?
 
Joined
Oct 8, 2011
Messages
223
RS gamers seem to make a habit of blaming their system in the belief that Runescape works flawlessly all the time. The latest update ("Nuke Bot") has apparently caused a myriad of problems for Runescape players, including lag, extremely low FPS.

Check the official forums: http://services.runescape.com/m=forum/forums.ws?25,26,423,63319466

If these problems persist on *other* games, then by all means drop another post in.

Keep up to date with patch notes/issues ;)
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top