Genshin Impact usning only 5-6 % GPU

Aceoi

Thread Starter
Joined
Sep 8, 2021
Messages
28
My problem is that the game GEnshin Impact uses only 5-6% of my GPU and runs with very low fps. This happens only on Genshin. I used to play with my integrated all the time but for some reason it started bugging and I cant exceed more that 1 fps on that game with only 5-6% GPU usage. I even tried reinstalling it but to no avail. Minecraft works fine and uses 100% GPU. My dedicated GPU is broken, so i use integrated, Intel UHD Graphics 620. These are my details...

Tech Support Guy System Info Utility version 1.0.0.9
OS Version: Microsoft Windows 10 Pro, 64 bit, Build 19043, Installed 20210902150918.000000+300
Processor: Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz, Intel64 Family 6 Model 142 Stepping 10, CPU Count: 8
Total Physical RAM: 8 GB
Graphics Card: AMD Radeon R7 M460
Hard Drives: C: 118 GB (48 GB Free); E: 935 GB (859 GB Free); F: 927 GB (380 GB Free);
Motherboard: Dell Inc. 0YDF7T, ver A00, s/n /9Y1LFP2/CN1296684E01EE/
System: Dell Inc., ver DELL - 1072009, s/n 9Y1LFP2
Antivirus: Bitdefender Antivirus, Enabled and Updated
 

Aceoi

Thread Starter
Joined
Sep 8, 2021
Messages
28
Also Fun fact it works fine on low settings
BUt stops working at lowest
However the fps at low isnt that much
 

Aceoi

Thread Starter
Joined
Sep 8, 2021
Messages
28
It sometimes works fine sometimes doesnt. . . ignore the above msg^ Plz help
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top