Getting some frame skipping in all games

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Helpmeee2

Thread Starter
Joined
Jul 30, 2016
Messages
14
I have a XFX RX 460 4GB and after the win 10 creators update its been giving me some frame skipping. I have since switched to win 8 but have not found any difference. This is making games unbearable to play. Specs are
I3 6100 8gbs of ram, MSI H110M Gaming Motherboard, and a thermaltake psu. Yes my temps are fine and everything like that.
 

flavallee

Frank
Trusted Advisor
Joined
May 12, 2002
Messages
84,057
Clipboard.jpg

MSI H110M Gaming (supports up to 32 GB of DDR4-2133 RAM)
Personally, I would add another 8 GB and run your PC with 16 GB.

Since we don't know how well you maintain and update your PC and what's installed and running in it, there could be a number of reasons why it's having gaming issues.

Have you checked the recommended (not minimum) system requirements of the games that you're playing in your PC?

--------------------------------------------------------------
 

Helpmeee2

Thread Starter
Joined
Jul 30, 2016
Messages
14
Yes and many of the games are easily run with the framerates going to 60fps or above like Overwatch,Fallout 4, BF1 And more. It only happens when I look left or right but not when I am just walking straight in game. Ram Might help for a couple of games like JC3 which is the only game I own that complains about 8gbs of ram but I don't see it helping with the issue. I have tried booting with no programs on and the issue still continues..
 

flavallee

Frank
Trusted Advisor
Joined
May 12, 2002
Messages
84,057
I'm not a hardware/gaming expert, so my input here is limited.

You didn't say if your gaming rig is running Windows 7 or Windows 8.1 or Windows 10 64-bit.

Have you installed the most current driver for your AMD Radeon RX 460 graphic card?
http://support.amd.com/en-us/download

---------------------------------------------------------------
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top