1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

gigaware speakers not working

Discussion in 'Do It Yourself (Not Computer-Related)' started by SunneeDays, Apr 10, 2018.

Thread Status:
Not open for further replies.
  1. SunneeDays

    SunneeDays Thread Starter

    Joined:
    Apr 10, 2018
    Messages:
    1
    I have a set of Gigaware speakers that connect to a central box with a separate round volume and bass control which usually has a blue light when it is on. No light comes on when I turn it on and no sound comes out either......Please Help
     
  2. cwwozniak

    cwwozniak Trusted Advisor

    Joined:
    Nov 28, 2005
    Messages:
    58,158
    First Name:
    Chuck
    Hi SunneeDays, and welcome to TSG.

    Make sure they a being powered from a known working power source. Beyond that, you will need to tell us the exact model number of the speakers.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1208365

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice