1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Grub stopping cd-boot

Discussion in 'Linux and Unix' started by tohm, Apr 4, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. tohm

    tohm Thread Starter

    Joined:
    Jul 14, 2005
    Messages:
    278
    I am reposting this from my post on ubuntuforums.org. They provide no help, and sure aren't very quick (need the use of the computer for certain deadlines coming up).

    Ok, so I am trying to uninstall Ubuntu for the sole reason that I would like to completely erase all data on my computer (all partitions, GRUB, everything) and restart.

    I have Feisty Fawn and Windows XP dual-booting right now, with GRUB as the bootloader. (Ubuntu IS working at the moment).

    I have the live cd that I want to use to reformat the hard drive (modify partitions, etc.) but the computer won't boot from it, instead it gets bypassed and goes straight to GRUB EVEN if I choose to boot from CD (and put it at the top of the list in the BIOS). Now, I chose to try and boot from the system rescue CD (that didn't work) and then from the Gparted liveCD in order to delete both partitions. After, I was going to reinstall windows, then ubuntu. CD's aren't able to boot, simply get bypassed and moves onto Grub.

    All I have now is functioning Ubuntu Feisty Fawn, and functioning Windows XP (thought that the system recovery CD that came with my laptop (no it doesn't include the microsoft system recovery that you can do "fixmbr", it's made for Toshiba) would wipe the whole hard drive clean, but it left Ubuntu partition and grub). AND I still have GRUB. So I'm basically stuck at square one now. No way to remove grub and no way to remove ubuntu. I just wish I could get in there somehow to delete the partitions, but it won't boot into gparted or the livecd or the system rescue cd made available on sourcefourge... I'm so stuck. I feel like ripping it out (the hard drive, it is).

    I was able to disable all other boot options except CD-DVD. It wont read gparted cd or system rescue (hangs on black page with single underscore (_), disk spins slowly foreeeeevvvverr), and doesn't boot to ubuntu live cd but just moves on to Grub, like I said. It boots to my laptop product recovery CD too, but that's useless. Only provides factory-default for the Windows partition. So I thought it was a problem with my CD drive. Turned out that the drive is not the problem.

    Processor on this computer: Intel 915GM

    Ok, so I was able to burn UBCD (Ultimate Boot CD, to see if it would boot from that so that I could erase partitions and fix the MBR) to a cd-r, and I was all ready to go. I turned off the computer and popped the CD in. Then I pressed F10 to choose a boot device - chose CD/DVD. Of course, the cd starts spinning, and shortly thereafter, grub loads and gives me my usual selection of Ubuntu and WinXP.

    I turn the computer off. I restart and enter BIOS where I set the order of boot to CD, HDD, FDD, LAN. Same thing happens as above.

    This time, I set boot order to CD/DVD, with all the rest disabled. Now the CD gets going but I receive a black screen saying this (repeats over and over again):
    Code:
    Intel UNDI, PXE-2.0 (build 082)
    Copyright (c) 1997-2000 Intel Corporation
    
    For Realtek RTL8139(X)/8130/810X PCI Fast Ethernet Controller v2.13 (020326)
    PXE-EG1: Media test failure, check cable
    PXE-M0F: Exiting PXE ROM.
    
    As per the search results at the top of google when searching 'PXE-EG1', I removed the HD and put it back in. No luck. I tried resetting the BIOS to default. No luck.

    I'm stuck with an unchangable computer, and it's making me want to throw it out the window. Actually, it's 3-ish years old so I wouldn't mind that much, but I wanted to use it exclusively for Ubuntu, which is why I need to do this (eventually getting rid of windows).

    Any help?
     
  2. arochester

    arochester

    Joined:
    Jan 17, 2007
    Messages:
    696
  3. lotuseclat79

    lotuseclat79

    Joined:
    Sep 12, 2003
    Messages:
    20,583
    Hi tohm,

    Did you check the cable (presumably on the CD drive) per the Media test failure message? Make sure the cable is properly seated.

    Is this computer a laptop with one CD/DVD drive? How much RAM? Do you only have one HD that is partitioned with both WinXP and Ubuntu? Or, do you have each OS on separate drives in a desktop computer?

    When I pop my Live CD into the computer, I never click on F10 to select a boot device as the BIOS is set to boot first from CD, then HD. I suggest you try this approach and let the Live CD time out or click <Enter> to bypass the 30sec timeout countdown in order to boot from the Live CD. I may try clicking on F10 to see what happens the next time I boot up. My thought is that by selecting F10, you override the BIOS setting to boot from your CD drive, and if you have more than one DVD/CD drive, the F10 may be selecting the drive w/o the Live CD. Just a theory based on your description - I could be wrong.

    My Grub boot menu is physically on the boot partition of the installed Linux FC3 HD. Where is your Grub boot menu installed? To check out your partitions, since you can boot into Ubuntu, issue the following command:
    $ sudo fdisk -l
    and post the results in this thread.

    Also, please post the contents of your Grub boot file - i.e. menu.1st?

    Do you have one or two DVD/CD devices? I have a DVD-RAM and a separate CD drive. My Live CD can boot from either - but, I mostly boot from the DVD-RAM drive.

    -- Tom
     
  4. saikee

    saikee

    Joined:
    Jun 11, 2004
    Messages:
    3,888
    Grub never stops the operation of a CD.

    PXE is to do with booting from a network. Thus the Bios has not been set to boot from a CD.
     
  5. monckywrench

    monckywrench

    Joined:
    Nov 28, 2007
    Messages:
    280
    Problems booting from live CDs vary.
    Ensure the live CD you use was burned at the slowest speed possible.
    Leave the CD in the "ejected" position and insert it during the POST so it will be spinning when the BIOS looks for it.
    Sometimes rapidly tapping the Enter key has gotten CDs to boot that did not otherwise. I am not sure why it worked, but I use live CDs very often.

    "It boots to my laptop product recovery CD too, but that's useless.
    If ONE live CD boots, others will boot if they are proper quality.
     
  6. tohm

    tohm Thread Starter

    Joined:
    Jul 14, 2005
    Messages:
    278
    Ok, you are all right.

    Lotusecat - laptopt, one hd, two partitions + swap, 512 mb ram. Apparently my BIOS is set to default to boot HDD before CD, then the others.

    I have managed to get the drive to function to write the media properly to the CD. Eventually I got it to boot from UBCD, and it seemed that the error was coming up because there was essentially nothing to boot from (cd turned out to be corrupt). I burned the cd in windows.

    I still don't understand why it was giving me the network error though.

    Of course, now I have error 22 in grub, after deleting the linux partition (which is on the same hd). Yes, I tried fixing the mbr, but it stalled and told me nothing. I tried with another few tools that come with UBCD, they all failed. But then on a hard drive diagnostic tool, it views the empty partition (2) as Format: N/A, size: 9GB, swap left, etc. So that means the partition is gone, really, and all I need now is to fix Grub. Yes, I tried getting the windows bootloader again, but as I said it keeps failing. And now I can't get into windows or linux.

    Perhaps a lesson - fix the mbr back to windows BEFORE removing partitions. Hm.
     
  7. saikee

    saikee

    Joined:
    Jun 11, 2004
    Messages:
    3,888
    Want you MBR back?

    Regardless it is a MS Windows or a Linux, last link in my signature refers. Mostly in Task B.

    The reason the network booting was activated because your Bios was trying every device in the booting queue.

    There are two booting queues. One is which device, CD, hard disk, flopply, network, USB devices etc, to boot first. The second one is with the different type of hard disks, internal, external, USB, SCSI etc, which one of them is to be booted first.

    A mobo has to have the ability to permit the CD drive booted first, otherwise no commercial OS can be installed there. If you buy a MS Windows you get a CD or DVD so every PC must has an option to boot the CD/DVD first. Just look deeper and you should find it, unless your CD is a USB device which may complicates the matter.
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - Grub stopping boot
  1. thenoobie2020
    Replies:
    2
    Views:
    300
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/700442

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice