1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Half RAM problem

Discussion in 'Hardware' started by DeputyDogg, Nov 15, 2011.

Thread Status:
Not open for further replies.
  1. DeputyDogg

    DeputyDogg Thread Starter

    Joined:
    Aug 19, 2009
    Messages:
    85
    Hi everyone,

    Further to my original post from last year:
    http://forums.techguy.org/hardware/988927-max-ram.html

    I have a problem where whatever amount of RAM in my PC, the BIOS registers only half.

    At the time of my original post, I had 8GB RAM installed. Only 4GB was registered by the BIOS (i.e. when I went into the BIOS, it showed the RAM at 4GB). However, the OS and CPU-Z registered all 8GB. Task Manager Resource Monitor showed that the missing 4GB was "Hardware Reserved". However, I believe this is just a red herring, as their shouldn't be any RAM reserved for hardware that can't also be accessed by additional resources. Besides, that theory falls down at the next point...

    Today I tried my computer with 12GB RAM. This time the BIOS saw 6GB, the OS saw all 12GB and resource monitor registers 6GB reserved for hardware.

    I haven't made any other hardware changes so the memory that is "hardware reserved" can't have increased by 2GB - I therefore think this is simply a non-header, used when the OS can't detect what the RAM is being used for. Maximum memory (msconfig) is unchecked and I can verify that the RAM sticks are all healthy.

    I thought it might be the motherboard, but can't understand why the RAM is halved. If I had increased the RAM and the BIOS limit had stayed at 4GB I would've understood. It's almost as if the BIOS is initially reading the full amount of RAM, and then halving it (perhaps during POST or something).

    Any thoughts? I have noticed I am not the only person to have faced this issue. Anyone have any experience in this matter?

    Thanks for your help, all!

    FYI - my specs:

    Mobo: ASUSTek Computer Inc P7P55 LX
    Processor: Intel Core i5 2.80GHz
    GFX: Radeon HD 5770 (1024MB)
    RAM: 2 x 4GB Corsair DDR3 PC3-10700H (667MHz) & 2 x 2GB Corsair DDR3 PC3-10700H (667MHz)
    OS: Windows 7 Home x64
     
  2. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    The only time I've seen anything like this ws when the wrong RAM was being used. In that case, someone had tried to use ECC RAM or registered RAM in a machine that needed non-ECC, non-"server" RAM.
     
  3. DeputyDogg

    DeputyDogg Thread Starter

    Joined:
    Aug 19, 2009
    Messages:
    85
    Hi Elvandil,

    Thanks for the response. I suppose you're right, but I'm fairly confident the RAM installed isn't ECC. THAT SAID - I have some more coming from crucial in the next day or so, specifically recommended for the mobo. Fingers crossed. I'm not hopeful though.

    Btw, I flashed my BIOS to the latest version, slightly hopeful after seeing some updates, but to no avail.

    Any advice from anyone is greatly appreciated.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1027014

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice