Hang up URLs or misdirection

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

deemac12

Thread Starter
Joined
May 29, 2012
Messages
57
Two days ago, non of my browsers, Sierra/Oracle/Firefox/Duckk-Duck on OS Catalina v10.15.6, Apple IMAC 27", would connect me to my Amazon.uk site.
By other means I could connect to its American site, but on using that site to change country back to the UK, the site froze.
The site hangs blank and reads, 'untitled'. The same thing happens when I use the 'UK' appellation on any Browser.

I have a couple of Window machines, WIN10 on a Samsung 49", a WIN 7 and a WIN 10 on an LG 27" and on all these OS I can surf the Amazon site OK.

I use the WIN 10 machines for Flight Sim and the APPLE for day to day commercial and domestic use, so it is irritating but not fatal.

It might be a coincidence, but, on the same day on which my fault appeared, an old friend. emailed me about how sorry he was that his computer had been hacked and he thought he would warn me. I haven't changed any passwords yet.
My issue is the only one I have.

Thank you
Derek McBride
 

TerryNet

Terry
Moderator
Joined
Mar 23, 2005
Messages
81,127
Closing dup. Please do not start multiple threads on the same topic.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top