Hard Drive found in BIOS but not in Win7 Disk Management

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

joshjpang

Thread Starter
Joined
Jan 9, 2006
Messages
40
Sorry, I think I posted this in the wrong place. It should be here in Hardware.

Long story short:

1) One random day, computer would not boot and I reformatted and re-installed Windows 7
2) My primary SATA hard drive with Windows 7 is working fine
3) My secondary SATA hard drive (my pictures!) is detected in BIOS but not in Disk Management. It used to work fine.
4) I've tried refreshing Disk Management, but no "unnamed drive" or anything shows up
5) I've tried moving the missing hard drive's SATA connection on the motherboard
6) I've tried downloading the latest motherboard RAID drivers and BIOS version from my motherboard's manufacturer

Now I'm thinking about buying an external USB enclosure for the SATA hard drive to get my pictures. I'd be out $20 and no longer have the drive directly connected to my motherboard, which I believe is a much faster connection.

Would you guys have any advice?

Thanks a lot and happy new year!
Josh
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top