1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

hard drive running in msdos compatibility

Discussion in 'Hardware' started by ronw1975, Jan 23, 2002.

Thread Status:
Not open for further replies.
Advertisement
  1. ronw1975

    ronw1975 Thread Starter

    Joined:
    Jan 22, 2002
    Messages:
    13
    I recently installed a new hard drive. My first hard drive is c:d:e:, and my other f:g:h:. I went into device manager (using safe mode in Windows 95) and deleted all the disk drive partitions. Dont ask why? And in trying to fix this problem deleted all my hard disk controllers also. Now PIIIx Bus Mastering PCI IDE controller has a resource conflict with the Standard IDE/ESDI hard disk controller. In the registry there is nothing wrong. Its all plug n play so i dont know what to do. I went back to safe mode and it showed primary and secondary controllers but the bus mastering still had exclamation point and all the partitioned disk drives were gone..... In trying to add new hardware I got error Msgsrv32 and Rundll32. I was able to add another Standard IDE/ESDI hard disk controller but it didnt do any good... My computer is an IBM Aptiva 2159 166mhz Windows95 4.00.950.a I also followed windows help in troubleshooting hardware conflicts and said basically it couldnt help me. Someone Please Help Me! Thank You
     
  2. brianF

    brianF

    Joined:
    Dec 2, 1999
    Messages:
    12,041
    See the following link, I think you will want to install the bus mastering drivers from intel, Check out the specs and see if they apply to your system

    Do you need the Intel Bus Master IDE driver?
    The Intel Bus Master IDE driver should be used only with the retail version of Windows 95 (4.00.950) or OEM Service Release 1 (4.00.950a).



    http://developer.intel.com/design/chipsets/drivers/busmastr/index.htm
     
  3. ronw1975

    ronw1975 Thread Starter

    Joined:
    Jan 22, 2002
    Messages:
    13
    I downloaded the OEM1 version for my windows and installed the Intel 82371SB PCI Bus Master IDE Controller. And I was still getting the same problems. After setting configuration on automatic on the bus master. I erased the standard ide/esdi hard disk controller and restarted. It showed a primary and secondary controller with red x's through them and the bus master did not have an exclamation point. Trying to set the primary and secondary controllers on current I restarted my computer and they disappeared and windows only found a single standard hard disk controller. I tried to reinstall the Intel bus master again and it said program needs a different version of windows and make sure your running the right windows plattform. Currently I still have the Intel 82371SB PCI Bus Master IDE Controller and a Standard IDE/ESDI hard disk controller. Very confusing. Thanks for trying to help me out, it is greatly appreciated and I will try to help out others, when possible. Thanks Again
     
  4. brianF

    brianF

    Joined:
    Dec 2, 1999
    Messages:
    12,041
    do you still have the error message or is the compatiblity mode message gone.
     
  5. ronw1975

    ronw1975 Thread Starter

    Joined:
    Jan 22, 2002
    Messages:
    13
    The intel bus master still has an exclamation mark through it and drives c-h are still running in msdos compatibility
     
  6. ronw1975

    ronw1975 Thread Starter

    Joined:
    Jan 22, 2002
    Messages:
    13
    same error when trying to reinstall the bus master error 102?
     
  7. brianF

    brianF

    Joined:
    Dec 2, 1999
    Messages:
    12,041
  8. brianF

    brianF

    Joined:
    Dec 2, 1999
    Messages:
    12,041
    check this first


    Click Start / Run, type REGEDIT (this is the system registry editor program), and click OK
    · Go to HKEY_LOCAL_MACHINE\SYSTEM\CURRENT CONTROL SET\SERVICES\VXD\IOS
    Look for a ‘NOIDE 01’ entry
    Click once on ‘NOIDE 01’
    Select Edit
    Select Delete
    · Reboot the system

    More from Intel, should help

    ftp://download.intel.com/support/chipsets/inf_bm.pdf
     
  9. ronw1975

    ronw1975 Thread Starter

    Joined:
    Jan 22, 2002
    Messages:
    13
    I read the list of things to do and am confused about a couple.
    When starting my computer in logged bootleg.txt by hitting f8 the screen blinks so quick i cannot read the int failure or success. And would you know how to examine the iso.log file?

    Also esdi_506.pdr in iosubsys. that provides 32 bit something, i opened it in notepad and it said will not run in dos mode, trap handler not called, sector mismatch, cylinder mismatch, head mismatch, data miscompare, access to drive failed irq? so punting removable ide. I dont have a removable ide. I think something is really screwed up with this drive.

    They also say disable enhanced features such as caching, turbo, rdtr, and select ide only in bios but they dont say how to do that?

    I'm going to go to the intel site and try to find and download a protected mode windows disk driver or windows 3.1 fast disk driver for the controller.

    Thanx Brian for helping me resolve this conflict created by my own stupidity... Anyone else is welcome to post a reply also
     
  10. brianF

    brianF

    Joined:
    Dec 2, 1999
    Messages:
    12,041
    what else do you have connected to the ide's, cdroms, etc.

    What positions are the drives in

    primary master hard drive
    primary slave ????
    Secondary Master ???
    Secondary Slave ???

    Have you checked your config.sys and autoexec.bat for drivers loading for cdrom's etc.

    If you have cdrom drivers loading these would be dos drivers, I would try remming them out, then reboot in safe mode, remove both bus mastering and standard controllers, check for noide line, reboot.
     
  11. ronw1975

    ronw1975 Thread Starter

    Joined:
    Jan 22, 2002
    Messages:
    13
    I'm running primary master and secondary slave
    I changed the config sys and autoexec bat to .old so nothing would boot up
    No noide in registry
    I want to uninstall the bus master i downloaded from intel, but now it tells me i'm running a different version of windows?
    Tried deleting everything in safe mode didnt work the same stuff just came back
    try adding new hardware but doesnt recognize primary or secondary and the bus master still has yellow exclamation
    My next step is reinstalling windows 95
    Do you think that will help?
    Running out of options and am getting frustrated
     
  12. ronw1975

    ronw1975 Thread Starter

    Joined:
    Jan 22, 2002
    Messages:
    13
    How do you rem something out and how do i check to see what i need to rem out?
     
  13. brianF

    brianF

    Joined:
    Dec 2, 1999
    Messages:
    12,041
    go to start/run/type sysedit and press enter.

    copy the config.sys and autoexec.bat tabs and paste them back into this thread.
     
  14. ronw1975

    ronw1975 Thread Starter

    Joined:
    Jan 22, 2002
    Messages:
    13
    Here is the information you wanted.
    @ECHO OFF
    C:\IBMAV95\IBMAVSH /F00
    PATH C:\MWW\DLL;C:\IBMTOOLS
    LH DOSKEY
    SET MWPATH=C:\MWW\DLL;C:\MWW\MWGAMES;C:\MWW\DSP
    REM The following is used by DOS games to recognize Sound Blaster hardware.
    REM If hardware settings are changed, please change this line as well.
    REM See the Mwave README file for instructions.
    SET BLASTER=A220 I5 D1
    SET LIBPATH=C:\MWW\DLL
    SET MWROOT=C:\MWW
    C:\IBMTOOLS\RESUME.EXE
    C:\IBMTOOLS\IBMPFILE.EXE
    REM
    REM
    REM

    [COMMON]
    DEVICE=C:\WINDOWS\HIMEM.SYS /TESTMEM:OFF
    BUFFERS=50
    FILES=40
    DEVICE=C:\WINDOWS\EMM386.EXE NOEMS I=E000-EFFF X=F000-FEFF
    DOS=HIGH,UMB
    DEVICEHIGH=C:\WINDOWS\COMMAND\IBMIDECD.SYS /D:IBMCD001 /P:170,15 /P:1E0,11
    DEVICE=C:\MWW\MANAGER\MWD50460.SYS
    REM Removing DWCFGMG.SYS may disable Mwave(games and modem) in native DOS mode
    REM DEVICE=C:\MWW\MANAGER\DWCFGMG.SYS

    I installed a new lucent 56k modem and unchecked the current in the mwave modem so i could use the sound card. Its never caused a problem i dont think.

    Heres the windows sys.ini its lengthy but i thought it might be important

    [boot]
    system.drv=system.drv
    drivers=mmsystem.dll power.drv
    user.exe=user.exe
    gdi.exe=gdi.exe
    sound.drv=mmsound.drv
    dibeng.drv=dibeng.dll
    comm.drv=comm.drv
    shell=Explorer.exe
    keyboard.drv=keyboard.drv
    fonts.fon=vgasys.fon
    fixedfon.fon=vgafix.fon
    oemfonts.fon=vgaoem.fon
    386Grabber=vgafull.3gr
    display.drv=pnpdrvr.drv
    mouse.drv=lmouse.drv
    *DisplayFallback=0
    SCRNSAVE.EXE=C:\WINDOWS\SYSTEM\MYSTIF~1.SCR

    [keyboard]
    subtype=
    type=4
    keyboard.dll=
    oemansi.bin=

    [boot.description]
    keyboard.typ=Standard 101/102-Key or Microsoft Natural Keyboard
    aspect=100,96,96
    display.drv=ATI Rage/Rage II PCI (ati_m64)
    mouse.drv=Logitech Mouse
    system.drv=Standard PC

    [386Enh]
    device=dva.386
    device=vshare.386
    DEVICE=C:\CSW70\CSDVXD.386
    DEVICE=C:\CSW70\CSSAFE95.386
    ebios=*ebios
    device=*vshare
    device=*dynapage
    device=*vcd
    device=*vpd
    device=*int13
    keyboard=*vkd
    display=*vdd,*vflatd
    mouse=*vmouse
    device=*vpowerd
    woafont=dosapp.fon
    device=*enable
    Paging=on

    [power.drv]
    PowerStatus=0

    [drivers]
    MWDBMIDI=C:\MWW\DLL\mwdbmidi.dll
    MWNOTIFY=C:\MWW\MANAGER\MWNOTWIN.DRV
    MWCONTND=C:\MWW\MANAGER\MWCONTND.DRV
    BLCKLSTW=C:\MWW\DLL\BLCKLSTW.DLL
    wavemapper=*.drv
    MSACM.imaadpcm=imaadpcm.acm
    MSACM.msadpcm=msadpcm.acm
    VIDC.MSVC=msvidc.drv
    VIDC.IV31=ir32.dll
    VIDC.IV32=ir32.dll
    VIDC.MRLE=msrle.drv
    VIDC.RT21=indeov.drv
    VIDC.YVU9=indeov.drv
    IV32=ir32.dll
    wave=mmsystem.dll
    midi=mmsystem.dll

    [iccvid.drv]

    [mciseq.drv]

    [mci]
    QTWVideo=C:\WINDOWS\SYSTEM\MCIQTW.DRV
    cdaudio=mcicda.drv
    sequencer=mciseq.drv
    waveaudio=mciwave.drv
    avivideo=mciavi.drv
    videodisc=mcipionr.drv
    vcr=mcivisca.drv
    videopuzzle=ibmpzz16.dll
    mpegvideo=ibmmpg16.dll
    VideoCD=ibmcdi16.dll
    MMMovie=mcimmp.drv

    [NonWindowsApp]

    [vcache]

    [display]

    [MWAVE]
    DMABufferSize=5632
    meio=C:\MWW\MANAGER\meiw0460.drv

    [Macx]
    DeviceBitmaps=OFF

    [nwnp32]

    [MSNP32]

    [drivers32]
    vidc.CVID=iccvid.dll
    VIDC.IV31=ir32_32.dll
    VIDC.IV32=ir32_32.dll
    vidc.MSVC=msvidc32.dll
    VIDC.MRLE=msrle32.dll
    msacm.msg711=msg711.acm
    MSACM.imaadpcm=imaadp32.acm
    MSACM.msadpcm=msadp32.acm
    MSACM.msgsm610=msgsm32.acm
    MSACM.trspch=tssoft32.acm
    msacm.lhacm=lhacm.acm
    msacm.msaudio1=msaud32.acm
    VIDC.IV50=ir50_32.dll
    msacm.iac2=C:\WINDOWS\SYSTEM\IAC25_32.AX
    VIDC.IV41=IR41_32.AX

    [Password Lists]
    1=C:\WINDOWS\1.PWL

    [Userinstallable.drivers]
    VIDC.CVID=iccvid.drv

    [TTFontDimenCache]
    0 12=5 12
    0 13=6 12
    0 14=7 14
    0 15=7 15
    0 16=8 16
    0 18=10 18
    0 20=10 20
    0 22=12 22

    Well I think this is where all the trouble is now if i only understood any of it...... Thanx for taking the time out Brian
     
  15. brianF

    brianF

    Joined:
    Dec 2, 1999
    Messages:
    12,041
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/65965

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice