1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Harddisk dead? Cables dead?

Discussion in 'Hardware' started by balls, Jun 21, 2009.

Thread Status:
Not open for further replies.
  1. balls

    balls Thread Starter

    Joined:
    Aug 5, 2007
    Messages:
    43
    Hi all, I've been through 3 harddisks now on my 3 year old system(8800 gt, 4 gb ram, e8400). Every (aprox) 6 months my harddisk dies(I think). On boot the bios will only read my two dvd drives, then proceed to "checking ide drives" and check for abnormally long time, and finally the nvidia boot agent fails to boot and I get some mac adress showing up in bios before I have to shut it down. What can be the cause to all my dying hdd's?

    I tried:
    Replugging the sata cable and try different slots.
    Checking if there is any hdd in under the voltage perimeters on bios and I can't seem to find my hdd anywhere!


    Can a faulty sata wire even be the cause?
    Help! Thanks:(
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/837145

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice