Headphones and speakers are not separate playback devices

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Claire_Kitty

Thread Starter
Joined
Nov 24, 2012
Messages
43
My audio setup is.. A set of speakers, a TV via HDMI, and headphones. I want to be able to have the TV be my default audio option when it's turned on and enabled, but I also want the headphones to take priority when those are connected. When I'm just using one monitor and not the tv, I want the speakers to play sound. In my playback devices section, the "speakers" item is both the headphones and the speakers, which I don't want. How can I separate the headphones and speakers into two items, so I can assign them separately?

Tech Support Guy System Info Utility version 1.0.0.2
OS Version: Microsoft Windows 8.1, 64 bit
Processor: AMD FX(tm)-6300 Six-Core Processor, AMD64 Family 21 Model 2 Stepping 0
Processor Count: 6
RAM: 8191 Mb
Graphics Card: AMD Radeon HD 7700 Series, 1024 Mb
Hard Drives: C: Total - 948416 MB, Free - 352933 MB;
Motherboard: BIOSTAR Group, A960D+
Antivirus: Windows Defender, Disabled
 

Tanis

Shane
Joined
May 29, 2006
Messages
4,292
I may be wrong, but I believe the only way to do that would be the have more than one sound card.

With one soundcard the audio is routed through a channel that goes to speakers and headphones sockets together, the speakers are then muted if something is plugged into the headphone socket. The two elements can not be assigned seperately.

The option you are after may be possible with a seperate, dedicated sound card but I am not an expert in that area so don't know for sure.
 

Claire_Kitty

Thread Starter
Joined
Nov 24, 2012
Messages
43
Well then, is there any way I can have headphones override the HDMI audio when they are plugged in?
 

Oddba11

Jim
Joined
May 12, 2011
Messages
8,361
They should do that automatically by default.

If not, with the headphones connected, check the audio configuration again and try setting the headphones as the default audio device.
 

Claire_Kitty

Thread Starter
Joined
Nov 24, 2012
Messages
43
Well, I would definitely do that, if that were possible. Speakers and Headphones are not separate items in the playback devices menu, and I don't want the speakers to override the HDMI. I want ..
Headphones > TV > speakers
 

Oddba11

Jim
Joined
May 12, 2011
Messages
8,361
Laptops get messy with issues like this, as some models use one chipset for all three outputs (as opposed to an audio chipset for speakers/headphones and a seperate audio chipset for HDMI).

Is the order correct when the HDMI is not connected?

You can try manually updating/reinstalling the audio drivers to see if that fixes the device recognition (and seperate devices).

Having said that, I'm not sure that you can configure preference between the three items. It's typically only speakers/headphones and you manually enable/disable HDMI as needed or set HDMI as default and let it "default" to the speakers/headphones configuration when HDMI is not connected.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top