Headset Help Please

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Arinai

Thread Starter
Joined
May 18, 2016
Messages
2
Hey guys so long story short my headset went kaput one day but it was old so I saw this coming, got a new headset and plugged it in, it was working fine for a short while then this one went kaput for seemingly no reason (while it was working i did some set up and noticed some sporatic static not sure if its relevant or not). I opened up device manager and it showed two unidentified devices, one under "Universal Serial Bus Controllers". I tried to update drivers, uninstall then scan for hardware changes and it seems like nothing I do works. When I try the latter immediately after I get a (what I would describe as) whooshing noise and then the sound audibly cuts and it pops back up in device manager as an unidentified device I'm at a complete loss as to what to do in this scenario, I tried a couple of other ports on the pc but the scene played out the same way. I have also gone so far as to have dont a restart of windows with deleting all of my personal files but the problem persists, the sad part is that I guarantee the headset works as well as the usb port because other devices in the usb port work and the headset on other devices works. I'm completely out of ideas at this point and would love any help :/
FYI I tried out the headset on another computer and it got the same error oddly enough but the first time I plugged it into my computer it was working just fine albeit with a slight amount of static. The headset has one 3.5 mm jack that plugs into a control panel midway down the cord and took that out and put it into my computer and it works just fine, it seems the problem lies in the compatibility between the usb portion and my PC itself. Please send help as I've been working on this for 3 days now and haven't really made any progress and just want to talk to my friends normally again :'( if I'm leaving out any information feel free to request it, I'll be able to reply relatively shortly. Thanks in advance friends!

Development: I know randomly have a command prompt popping up and firing away something like 15 lines before disappearing, overall it takes like a half a second so I can never capture whats going on.
 

Oddba11

Jim
Joined
May 12, 2011
Messages
8,338
Brand and model of the headset.

Also, if it has a 3.5mm jack, it can be connected directly to the PC. If the issue only occurs when using the "adapter", it sounds like the adapter is faulty.
 

metallica5456

Andrew
Trusted Advisor
Joined
Apr 1, 2013
Messages
10,340
For audio related products like headsets or mice and keyboards I recommend Logitech.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top