1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved Headset playing sound from microphone.

Discussion in 'Linux and Unix' started by RotundCat, Nov 21, 2018.

Advertisement
  1. RotundCat

    RotundCat Thread Starter

    Joined:
    Nov 21, 2018
    Messages:
    3
    I am using Linux Mint 19 Cinnamon on a Dell Latitude E5470. I have a Sennheiser HD 4.50BTNC headset.
    My headset is playing the sounds that are heard through the microphone, it started when I turned on the headset microphone in sound settings and continued even when i turned on the laptop microphone back on. Before this the sound was fine.
    When I used Windows 10 it happened when i turned the microphone on, but stopped when the microphone was turned off.
    This doesn't happen when I connect the headset to my phone.
    I have tried restarting the laptop.
     
  2. tecknurd

    tecknurd

    Joined:
    May 28, 2018
    Messages:
    144
    Microphones can't produce sound. They can only receive sound. The noise that you are probably hearing is the data bus noise that are induced into the audio lines. Your phone may have some, but can't hear it. To fix this use a DAC that uses external power.
     
  3. RotundCat

    RotundCat Thread Starter

    Joined:
    Nov 21, 2018
    Messages:
    3
    Ah sorry, what I meant was that sound being picked up by the microphone was being played by the headphones.
     
  4. RotundCat

    RotundCat Thread Starter

    Joined:
    Nov 21, 2018
    Messages:
    3
    Fixed it by changing OS to Ubuntu.
     
  5. tecknurd

    tecknurd

    Joined:
    May 28, 2018
    Messages:
    144
    Linux Mint is based on Ubuntu. Linux Mint has minor differences. Using Ubuntu is not a fix, but a work around. A work around is not a fix. Also can't learn anything like why it happens when referring to a work around instead of real fix.

    In Linux type alsasound -V all using terminal program (konsole, gnome-terminal, xterm, rxvt). Play with the settings. I can't give you what settings to change because it's different from one sound card or sound device to another sound device.

    In Windows, make sure stereo mix is not selected.

    In any operating system, the recording program can be the problem. I don't know what settings to suggest to change because there is many recording programs and have different variation of settings.
     
  6. Miqw7394

    Miqw7394

    Joined:
    Apr 1, 2016
    Messages:
    117
    First Name:
    Mike
    Personally, I've found the answer to using a headset in Linux. I'm now using the Logitech H340 USB headset.....which has its own sound card built-in to the rather 'chunky' USB connector. Makes using a headset an absolute doddle; simply switch sound cards!

    The card has its own 'phone volume and 'boom mike' level controls built in.....and they're all that is needed. Simply set the phone's sound card as the default one while using it, and adjust the controls using

    "alsamixer"

    in the terminal. (Or use your distro's default sound mixer.)

    Sorted..!


    Mike. ;)
     
    Last edited: Jan 14, 2019 at 7:46 PM
  7. tecknurd

    tecknurd

    Joined:
    May 28, 2018
    Messages:
    144
    I did mean alsamixer. By typing alsamixer -V all in the terminal will give every control that is not usually shown by default by running just alsamixer. It's best to use alsamixer instead what sound mixer that comes with the desktop environment or window manager is being used. All Linux distributions are the same.

    Sorry about the confusion.

    If the headset is a sound card, setting it be the default is not easy. Some distributions uses PulseAudio to provide a GUI way to adjust the audio and change to different audio outputs. If PulseAudio is not being used, you have to do the following assuming mplayer is installed and you are OK using the terminal.

    mplayer -ao alsa:device=hw:1 file.mp3

    This should use the second sound card for example the headset. Changing the 1 to 0 will then use the first sound card.

    To make "mplayer -ao alsa:device=hw:1 file.mp3" be just "mplayer file.mp3" and make any program like Firefox to be play through the headset. You will have to make the following file and store it in "$HOME/.asoundrc". This file is not always created, so you have to create it.
    Code:
    pcm.!default {
       type hw
    # Sound Card 1
    # card 0
    # Sound Card 2
       card 1
    }
    
    ctl.!default {
       type hw          
    # Sound Card 1
    # card 0
    # Sound Card 2
       card 1
    }
    
    PulseAudio in Linux is overwhelming redundant because PulseAudio does things that ALSA already does. ALSA is the main sound system in Linux. The main purpose of PulseAudio development is sending audio through the network to another computer running PulseAudio. PulseAudio runs on top of ALSA. There is a performance penalty using PulseAudio. It's best to remove PulseAudio to get back the performance, but this is easy said then done when distributions have PulseAudio installed by default and configured to only use PulseAudio.
     
  8. Miqw7394

    Miqw7394

    Joined:
    Apr 1, 2016
    Messages:
    117
    First Name:
    Mike
    @ tecknurd:-

    Have to agree about PulseAudio, I must admit. It grossly overcomplicates what always used to be a simple, reliable system.....ALSA.

    For me, it's remarkably easy to switch sound cards, since one of our Puppy devs has written a script specifically for doing just that.....and you also get a rather smart GUI to make it easier to use. It certainly simplifies the process for newbies (and even many of the 'regulars'!)

    I have no problem with PulseAudio itself; its intention was always to give finer-grained control than what ALSA alone was capable of. It does that very well. My 'beef' is with the distro developers, who have, as you say, made PulseAudio the 'default', whether you want it or not. Pulse always uses ALSA as the back-end, true.....but to use it on its own now has the average user having to jump through hoops to achieve what should be easy to start with.....

    Much easier, to my way of thinking, to make PulseAudio an easy-to-use 'option' that works 'on top' of ALSA if you want it.....but leave ALSA to work as it has always done if that's how the user wants it.

    This diagram shows, quite clearly, just how much extra complexity PulseAudio adds to the 'mix'!

    https://rudd-o.com/linux-and-free-software/how-pulseaudio-works


    Mike. ;)
     
    Last edited: Jan 16, 2019 at 12:37 PM
  9. tecknurd

    tecknurd

    Joined:
    May 28, 2018
    Messages:
    144
    PulseAudio can't be used as stand-alone. ALSA is the kernel's or Linux's main low-level sound system. PulseAudio is a service or technically a daemon that requires a hardware connection like ALSA to do the dirty work. The diagram that you posted shows that.

    Besides the performance penalty that PulseAudio puts on the computer. PulseAudio is not good if the user wants the sound to be set just right on volume, so it doesn't clip. PulseAudio has trouble using software mixer controls. All sound cards vary what mix controls should be set so it doesn't clip if master volume is set at 100%. PulseAudio doesn't just adjust the master volume. It adjusts the PCM output of the sound card after the master volume is adjusted to 100%. I tried setting PulseAudio to not do this in its configs, but it still does it. Setting PCM to 100% is not always the correct setting for all sound cards. Sound card varies of their output capabilities. Setting PCM to a correct setting so the output doesn't clip is essential to excellent sound. Some sound cards PCM could be front. The convenience that PulseAudio provides penalizes the sound quality and performance of the computer. Using ALSA doesn't have these problems when a media button is pressed to adjust volume.

    I use Gentoo or Calculate Linux and I have the luxury of disabling PulseAudio and not including it for any program that I install. I use asoundrc for sound customizations.
     
  10. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Short URL to this thread: https://techguy.org/1219417

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice