HELP! Can't access my external HD enclosure

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

brodie1980

Thread Starter
Joined
Dec 29, 2010
Messages
1
Ok so I have a WD SATA hard drive in and external enclosure. Now I can't get it to connect to any PC. I took it to a repair shop and they said the drive might be corrupt. They tried connecting it directly via SATA cable and still no luck. The promising thing is the drive sounds good. It powers up fine. Spins good from what I can hear. I can even see it in my windows explorer but cannot access the drives. Also the drive is partitioned into 2 drives if that helps. Does anyone know if this is fixable? I really don't want to go to a data recovery place and pay over $500 when i think the problem is much simpler. Any help would be greatly appriciated. Thanks!
 
Joined
May 3, 2006
Messages
22,466
If you can see it in Windows Explorer you should be able to run checkdisk on it in My Computer. Find the drive in My Computer, right click it and choose "Properties", "Tools," "Error Checking" and put checks in both boxes and then hit apply OK. If it says it has to reboot to do it well do so.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top