Help! Can't view photos/documents on External HD? (Windows 8.1)

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

oniiku

Thread Starter
Joined
Feb 11, 2009
Messages
72
Hey everyone, I hope this is the right area to post this.

I recently just upgraded to a new computer that's running Windows 8.1 and had all my media files (mostly photos and text documents) from the old XP computer saved on an external hard drive. I plug the external HD to my new computer and can access the drive itself, but I can't view nearly 90% of the content! :( Videos and music files seem to work fine, but none of the photos or document/text files will open, which are the most important to me.

The document files say "access is denied" and can't be opened and when I try to view the photos it says "Windows photo viewer can't open this picture because you don't have the correct permission to access the file location". Even when I try to move or copy&paste the files out of the external HD, it denies me.

How can I fix this problem? How do I get permission to my own files? I tried to "take ownership" of the drive...but I'm not so confident that I'm doing it right because I haven't been able to find any instructions on doing it with Windows 8.1 ...
and what I'm doing still hasn't helped.

ANY help or suggestions that anyone can give me on how to get permission to view all my photos/documents again on my new computer would be awesome. I'm a photographer so I'm pretty horrified at the idea of not being able to access my photos. :confused:
The drive itself works fine and all the files were accessible on the older computer...so why can't I access them on the new computer? Isn't that what saving to external HD's is good for? So you don't lose all your important files...

Please help!

** Update: I have also just tried the TakeOwnership registry hack, and it hasn't fixed the problem either. Still getting the "Windows photo viewer can't open this picture because you don't have the correct permission to access the file location" whenever I try to open a photo from the drive, even after "taking ownership" using the reg hack. I did not try the hack on the entire drive, just the individual photos that won't work. **
 

oniiku

Thread Starter
Joined
Feb 11, 2009
Messages
72
If I had the problem I would try: How to Add "Take Ownership" to Context Menu in Windows 8 and 8.1.

This looks like it may work, but if you read the comments it didn't work for everybody: How to Take Full Ownership of Files & Folders in Windows 8.

Thanks for the suggestion. I tried the first method using the "Take Ownership" Context Menu and it didn't change anything. I downloaded the Take Ownership with Pause Context Window and it didn't pause the context window either. So I can't even tell if this is really changing anything. I'm wondering if there could be something that's blocking me from making these changes? I'm the only user of this computer (again it's brand new) and I'm set to Administrator. This computer does have things like McAfee installed on it with default settings...no idea if something like that would even be preventing me from making these changes or not? Going to try the second suggestion you gave me and try to manually do it.
 

oniiku

Thread Starter
Joined
Feb 11, 2009
Messages
72
If I had the problem I would try: How to Add "Take Ownership" to Context Menu in Windows 8 and 8.1.

This looks like it may work, but if you read the comments it didn't work for everybody: How to Take Full Ownership of Files & Folders in Windows 8.
UPDATE:
Well I managed to get the Take Ownership with Pause to work. It says it successfully made all permissions to the Administrator, but I still cannot access any of my photos or documents. Same message saying "access denied" and "Windows photo viewer can't open this picture because you don't have the correct permission to access the file location"

Going to try and do it manually, I guess. :( Will post back.
 

TerryNet

Terry
Moderator
Joined
Mar 23, 2005
Messages
81,406
If you can't get the ownership stuff to work try a Live CD of Puppy Linux (or another Linux distribution) to copy the files.

P.S.--I moved the thread from Hardware to Windows 8.
 

Macboatmaster

Trusted Advisor
Spam Fighter
Joined
Jan 14, 2010
Messages
24,593
After you have taken ownership of the drive check that YOU have full permissions




So for example using option 4 on here
http://www.eightforums.com/tutorial...le-folder-drive-registry-key-windows-8-a.html


properties and security tab which you will only see if the file system is NTFS
then if you still receive the error check as outlined here that having taking ownership you have full permissions


So here
http://www.eightforums.com/tutorial...low-deny-access-users-groups-windows-8-a.html


on option 3 check on the image shown at item 6 - that YOU the owner has full control




ALTERNATIVELY try accessing the drive via the system admin account - it just maybe that this account will already have full control


cmd prompt with admin rights
type


Net user administrator /active:yes

press enter
you should receive confirnation then exit from cmd prompt reboot and log into that account unless you have set one there is no password on this account it is left blank


A cmd prompt with admin rights has the cmd window headed
Administrator Command Prompt
and not just Command Prompt
to get there right click the Microsoft flag left of taskbar and click cmd prompt admin


DO NOT keep that account activated it is a security risk
if it does not grant you access simply repeat the cmd changing yes to no


HERE if you find it helpful are the instructions for taking ownership etc in brief
1. Right-click on the drive and select "Properties"
2. On the Security tab Click on "Edit"
3. Select "Add"
4. In the box type "Everyone" and select "OK"
5. Select the "Everyone" user from the list, check the "Full Control" option below and click on "Apply" and "OK"
6. On the next screen select the "Everyone" user and click on the "Advanced" button
7. Select the "Owner" tab and click on "Edit"
8. Click on "Other users or groups"
9. Type "Everyone" in the box and select "OK"
10. On the next screen click on "Apply" and "OK"
 

oniiku

Thread Starter
Joined
Feb 11, 2009
Messages
72
If you can't get the ownership stuff to work try a Live CD of Puppy Linux (or another Linux distribution) to copy the files.

P.S.--I moved the thread from Hardware to Windows 8.

After you have taken ownership of the drive check that YOU have full permissions




So for example using option 4 on here
http://www.eightforums.com/tutorial...le-folder-drive-registry-key-windows-8-a.html


properties and security tab which you will only see if the file system is NTFS
then if you still receive the error check as outlined here that having taking ownership you have full permissions


So here
http://www.eightforums.com/tutorial...low-deny-access-users-groups-windows-8-a.html


on option 3 check on the image shown at item 6 - that YOU the owner has full control




ALTERNATIVELY try accessing the drive via the system admin account - it just maybe that this account will already have full control


cmd prompt with admin rights
type


Net user administrator /active:yes

press enter
you should receive confirnation then exit from cmd prompt reboot and log into that account unless you have set one there is no password on this account it is left blank


A cmd prompt with admin rights has the cmd window headed
Administrator Command Prompt
and not just Command Prompt
to get there right click the Microsoft flag left of taskbar and click cmd prompt admin


DO NOT keep that account activated it is a security risk
if it does not grant you access simply repeat the cmd changing yes to no


HERE if you find it helpful are the instructions for taking ownership etc in brief
1. Right-click on the drive and select "Properties"
2. On the Security tab Click on "Edit"
3. Select "Add"
4. In the box type "Everyone" and select "OK"
5. Select the "Everyone" user from the list, check the "Full Control" option below and click on "Apply" and "OK"
6. On the next screen select the "Everyone" user and click on the "Advanced" button
7. Select the "Owner" tab and click on "Edit"
8. Click on "Other users or groups"
9. Type "Everyone" in the box and select "OK"
10. On the next screen click on "Apply" and "OK"
If I had the problem I would try: How to Add "Take Ownership" to Context Menu in Windows 8 and 8.1.

This looks like it may work, but if you read the comments it didn't work for everybody: How to Take Full Ownership of Files & Folders in Windows 8.

Thank you both for your help.

I did the first steps that Macboatmaster suggested, using the tutorial. I was able to switch all the permissions for the entire drive over to me (User: Hana H.) so now I'm the owner. However, I still cannot access any of the files. Previously after using the TakeOwnership reg menu, the owner was "Administrator" and now it's me (my user) so I'm confused why this still isn't working...:( I must be doing something wrong. There seems to be a lot of dublicates of the same things in the Security list. Is that normal? There are two "Users (MATSUMOTOJR/Users)" one of them has "Special" while the other has "Read & execute". On group or user names under the properties it's set on "Everyone". I've included a screencap of what everything looks like now...hoping that someone will notice some kind of error or problem and help me to fix it so I can get this drive back. :confused: Thanks so much for your time!


 

Macboatmaster

Trusted Advisor
Spam Fighter
Joined
Jan 14, 2010
Messages
24,593
I am puzzled at the moment as to how to proceed on what is shown in your screenshots
Try this
cmd prompt with admin rights
type


Net user administrator /active:yes

press enter
you should receive confirnation then exit from cmd prompt reboot and log into that account unless you have set one there is no password on this account it is left blank


A cmd prompt with admin rights has the cmd window headed
Administrator Command Prompt
and not just Command Prompt
to get there right click the Microsoft flag left of taskbar and click cmd prompt admin


DO NOT keep that account activated it is a security risk
if it does not grant you access simply repeat the cmd changing yes to no



as it appears that System has full control
 
Joined
Dec 25, 2014
Messages
1,081
That shows you took ownership of Drive D which that says is the backup partition of your HDD. The external drive should be E or some other Letter.
 

oniiku

Thread Starter
Joined
Feb 11, 2009
Messages
72
I am puzzled at the moment as to how to proceed on what is shown in your screenshots
Try this
cmd prompt with admin rights
type


Net user administrator /active:yes

press enter
you should receive confirnation then exit from cmd prompt reboot and log into that account unless you have set one there is no password on this account it is left blank


A cmd prompt with admin rights has the cmd window headed
Administrator Command Prompt
and not just Command Prompt
to get there right click the Microsoft flag left of taskbar and click cmd prompt admin


DO NOT keep that account activated it is a security risk
if it does not grant you access simply repeat the cmd changing yes to no



as it appears that System has full control
Thank you. I will try this and report back.
 

oniiku

Thread Starter
Joined
Feb 11, 2009
Messages
72
That shows you took ownership of Drive D which that says is the backup partition of your HDD. The external drive should be E or some other Letter.

When I plug the drive into the USB, drive D is the one it always pops up as. I've switched the plug to three different USB plugs and it's always the same D drive. :confused: Could that be the problem? Why would it be coming up as D?
 

oniiku

Thread Starter
Joined
Feb 11, 2009
Messages
72
I am puzzled at the moment as to how to proceed on what is shown in your screenshots
Try this
cmd prompt with admin rights
type


Net user administrator /active:yes

press enter
you should receive confirnation then exit from cmd prompt reboot and log into that account unless you have set one there is no password on this account it is left blank


A cmd prompt with admin rights has the cmd window headed
Administrator Command Prompt
and not just Command Prompt
to get there right click the Microsoft flag left of taskbar and click cmd prompt admin


DO NOT keep that account activated it is a security risk
if it does not grant you access simply repeat the cmd changing yes to no



as it appears that System has full control
I just tried cmd prompt with admin rights...it didn't help. :( I still cannot access the content on my external hard drive and receive the same error about "not having permissions/access denied".

I am so frustrated with this...:mad:

Do you have any more ideas on how I can get my content off this drive?
Thank you for your help...
 

Macboatmaster

Trusted Advisor
Spam Fighter
Joined
Jan 14, 2010
Messages
24,593
Before we proceed to the suggested use of the Linux disc try this


Do you still have the old XP computer
If so the easy answer may well be to connect the MAXTOR to that computer get the data from the drive to a flash pen and take that to the windows 8.1 computer
If you copy ONLY the actual jpeg files and doc files they then should be accessible on the 8.1


Try it first with just a couple rather than filling the flash pen and then finding that it will not work


If for some reason you cannot do that connect the drive back to 8.1 and go back to a cmd prompt with admin rights in your user account


Check that the drive is still allocated D


copy and paste this


takeown /F "D:" /R /D Y

exit out of the cmd prompt - do not reboot and then try and access the drive
that cmd grants the current user full rights to the drive




If neither of those work I will send you guide for using Linux
 

oniiku

Thread Starter
Joined
Feb 11, 2009
Messages
72
Before we proceed to the suggested use of the Linux disc try this


Do you still have the old XP computer
If so the easy answer may well be to connect the MAXTOR to that computer get the data from the drive to a flash pen and take that to the windows 8.1 computer
If you copy ONLY the actual jpeg files and doc files they then should be accessible on the 8.1


Try it first with just a couple rather than filling the flash pen and then finding that it will not work


If for some reason you cannot do that connect the drive back to 8.1 and go back to a cmd prompt with admin rights in your user account


Check that the drive is still allocated D


copy and paste this


takeown /F "D:" /R /D Y

exit out of the cmd prompt - do not reboot and then try and access the drive
that cmd grants the current user full rights to the drive




If neither of those work I will send you guide for using Linux


I do not have the old XP to try the first step on. It completely stopped working and does not start up. :(
So I will try the second step you mentioned with the D drive. Then I will report back.
Is it okay to reboot after I try it though? Or is it unsafe?

Also, can you explain briefly what the Linux is?
I don't understand what that is.
Thank you for your patience.
 

TerryNet

Terry
Moderator
Joined
Mar 23, 2005
Messages
81,406
Linux is a kernel (patterned after the Unix kernel) around which many (over a hundred I think) distributions (Operating Systems) have been built. Ubuntu is the most popular, and has many derivatives. Puppy Linux is a very small one that is good for this type of file recovery task. Almost all Linux distributions can run as a "Live CD", meaning that they need not be installed. "CD" now includes DVD and USB flash drive.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top