1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Help Needed with XP - Win 7 Network

Discussion in 'Networking' started by Decetch, Oct 9, 2010.

Thread Status:
Not open for further replies.
Advertisement
  1. Decetch

    Decetch Thread Starter

    Joined:
    Aug 13, 2009
    Messages:
    82
    Hi Everyone,

    Would someone please give me some assistance setting up a two computer (1 XP - 1 Win 7) network.

    I'm using a DLink DSL 502T router. The XP computer is connected via the USB port and the Win 7 computer is connected via the Ethernet port. Both computers have internet access. On the XP computer the icon with the two computer screens has a red cross on it and says "Local Area Connection - A network cable is unplugged". There are no cables unplugged and the internet connection on both computers is working. However, I am unable to configure file and printer sharing.
    Would someone please talk me through this?

    Thank you.

    John
     
  2. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,184
    First Name:
    Terry
  3. Decetch

    Decetch Thread Starter

    Joined:
    Aug 13, 2009
    Messages:
    82
    Hi TerryNet,

    Thanks for the prompt reply. I think you gave me some assistance with this problem some time ago but I had to drop it due to other commitments at the time. So I've returned for another try. Unfortunately, I didn't have any joy with the PCWorld link. I remember trying this once before and I've just tried again and still no luck. As I've said, no problem with internet sharing with the router but unfortunately the two computers just don't "see" each other for file and printer sharing so obviously something is not configured correctly but I don't know what it is. Any other advice you can give me?

    Thanks.

    John
     
  4. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,184
    First Name:
    Terry
    If don't "see" means cannot ping each other the problem is usually a firewall. I didn't check the documentation for your router and am assuming that the USB connection acts a special LAN port. Let's see the following for both PCs ...

    Start, Run, CMD, OK to open a command prompt:
    (For Vista or 7 type CMD in the Search box after Start)

    Type the following commands:

    nbtstat -n

    IPCONFIG /ALL

    [Note that there is no space between the slash and ALL.]

    Right click in the command window and choose Select All, then hit Enter.
    Paste the results in a message here.

    If necessary use a text file and removable media to copy the results to a computer with internet access.
     
  5. Decetch

    Decetch Thread Starter

    Joined:
    Aug 13, 2009
    Messages:
    82
    Hi TerryNet,

    Below is the IPCONFIG/ALL for XP

    I'm not sure if I ran the nbtstat-n command correctly. I got this:

    C:\Users\John>nbtstat-n
    'nbtstat-n' is not recognized as an internal or external command,
    operable program or batch file.

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.
    C:\Documents and Settings\Administrator.JOHN.000>ipconfig/all
    Windows IP Configuration
    Host Name . . . . . . . . . . . . : john
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : Yes
    WINS Proxy Enabled. . . . . . . . : No
    Ethernet adapter Local Area Connection:
    Media State . . . . . . . . . . . : Media disconnected
    Description . . . . . . . . . . . : SURECOM EP-320X-R 100/10/M PCI Adapt
    er
    Physical Address. . . . . . . . . : 00-00-21-CD-45-84
    Ethernet adapter Local Area Connection 5:
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : D-Link USB Remote NDIS Network Devic
    e
    Physical Address. . . . . . . . . : 00-0F-3D-92-EE-D7
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 10.1.1.2
    Subnet Mask . . . . . . . . . . . : 255.0.0.0
    Default Gateway . . . . . . . . . : 10.1.1.1
    DHCP Server . . . . . . . . . . . : 10.1.1.1
    DNS Servers . . . . . . . . . . . : 10.1.1.1
    Lease Obtained. . . . . . . . . . : Sunday, 10 October 2010 12:34:07 PM
    Lease Expires . . . . . . . . . . : Sunday, 10 October 2010 1:34:07 PM
    C:\Documents and Settings\Administrator.JOHN.000>

    This is the Win 7 Computer

    Microsoft Windows [Version 6.1.7600]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.
    C:\Users\John>ipconfig/all
    Windows IP Configuration
    Host Name . . . . . . . . . . . . : John-PC
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    Ethernet adapter Local Area Connection:
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Atheros AR8121/AR8113/AR8114 PCI-E Ethern
    et Controller
    Physical Address. . . . . . . . . : E0-CB-4E-24-F9-B4
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::f830:f60a:e50:da2c%11(Preferred)
    IPv4 Address. . . . . . . . . . . : 10.1.1.3(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.0.0.0
    Lease Obtained. . . . . . . . . . : Sunday, 10 October 2010 11:32:39 AM
    Lease Expires . . . . . . . . . . : Sunday, 10 October 2010 1:32:39 PM
    Default Gateway . . . . . . . . . : 10.1.1.1
    DHCP Server . . . . . . . . . . . : 10.1.1.1
    DHCPv6 IAID . . . . . . . . . . . : 249613134
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-21-E5-51-E0-CB-4E-24-F9-B4
    DNS Servers . . . . . . . . . . . : 10.1.1.1
    NetBIOS over Tcpip. . . . . . . . : Enabled
    Tunnel adapter isatap.{872274E5-F159-4333-81E4-F819527E1DE8}:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    Tunnel adapter Teredo Tunneling Pseudo-Interface:
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:5c:288b:f5fe:fefc(Prefer
    red)
    Link-local IPv6 Address . . . . . : fe80::5c:288b:f5fe:fefc%13(Preferred)
    Default Gateway . . . . . . . . . : ::
    NetBIOS over Tcpip. . . . . . . . : Disabled
    C:\Users\John>

    Thanks.

    John
     
  6. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,184
    First Name:
    Terry
    As assumed, they are on the same LAN. The nbtstat -n from each would give some additional info. The "'nbtstat-n' is not recognized ..." confirms that you need the space before the minus sign.
     
  7. Decetch

    Decetch Thread Starter

    Joined:
    Aug 13, 2009
    Messages:
    82
    Hi TerryNet,

    This XP computer.


    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.
    C:\Documents and Settings\Administrator.JOHN.000>nbtstat -n
    Local Area Connection:
    Node IpAddress: [0.0.0.0] Scope Id: []
    No names in cache
    Local Area Connection 5:
    Node IpAddress: [10.1.1.2] Scope Id: []
    NetBIOS Local Name Table
    Name Type Status
    ---------------------------------------------
    JOHN <00> UNIQUE Registered
    WORKGROUP <00> GROUP Registered
    JOHN <20> UNIQUE Registered
    WORKGROUP <1E> GROUP Registered
    WORKGROUP <1D> UNIQUE Registered
    ..__MSBROWSE__.<01> GROUP Registered
    C:\Documents and Settings\Administrator.JOHN.000>

    This is Win 7 computer

    Microsoft Windows [Version 6.1.7600]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.
    C:\Users\John>nbtstat -n
    Local Area Connection:
    Node IpAddress: [10.1.1.3] Scope Id: []
    NetBIOS Local Name Table
    Name Type Status
    ---------------------------------------------
    JOHN-PC <00> UNIQUE Registered
    WORKGROUP <00> GROUP Registered
    JOHN-PC <20> UNIQUE Registered
    WORKGROUP <1E> GROUP Registered
    WORKGROUP <1D> UNIQUE Registered
    ..__MSBROWSE__.<01> GROUP Registered
    C:\Users\John>

    Thanks.

    John
     
  8. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Well, there's one problem. Both of them think they're the master browser, this is normally due to firewall settings.


    Turn off any firewalls for debugging. If the firewall is the problem, you'll have to configure it to allow access to "trusted zone" addresses. Note that some firewalls must be completely uninstalled to stop them from affecting your networking.

    Hold the Windows key and press R, then type CMD to open a command prompt.

    In the command prompt window that opens, type type the following commands:

    PING each remote computer by IP address, and if successful, PING by name. Open a command prompt as described above and type.

    PING <ip address>
    or
    PING <computer name>

    Where:
    <ip address> - is the x.x.x.x IP address
    <computer name> - is the computer name

    A failure to PING is almost always a firewall configuration issue. Any failure to PING needs to be corrected before you go any farther.

    Note: You can obtain the IP address and computer name of a computer by opening a command prompt (DOS window) and typing IPCONFIG /ALL. This should work for any Windows version. The IPCONFIG /ALL display will provide a wealth of useful information for debugging your network connection.

    Check your Services are Started on all PCs:
    • COM+ Event System (for WZC issues)
    • Computer Browser
    • DHCP Client
    • DNS Client
    • Network Connections
    • Network Location Awareness
    • Remote Procedure Call (RPC)
    • Server
    • TCP/IP Netbios helper
    • Wireless Zero Configuration (XP wireless configurations)
    • WLAN AutoConfig (Vista wireless configurations)
    • Workstation

    Note: You can check the services in Control Panel, Administrative Tools, Services.

    All of these services should be started, and their startup type should be automatic.

    If a service is not running, open it's properties and check the dependencies. Check each of the dependencies and see which one is preventing the service from running. Checking the event log is also a good idea here, there may be clues to what is failing.


    All computers should be in the same workgroup for computer browsing to function properly. File & Print Sharing has to be enabled on any computer you wish to share files or printers from. You also need to actually share the resource in question from My Computer, right click on the drive/printer/folder, and select sharing.

    If you encounter difficulties accessing computers that are visible in Network Places (Network and Sharing Center in Vista), make sure the computer being accessed has an account with the same name/password as the system connecting to it uses to login. NOTE: Vista's default is to require a password on the account to enable file/print sharing.

    While the default NetBIOS setting is correct for normal network configurations, it's possible for it to be altered, and it costs nothing to make sure it's correct. NETBIOS over TCP/IP must be enabled for normal network browsing. You can open a command prompt as described above and type the following command: nbtstat -n. This will display the status of NetBIOS or indicate it's not configured.
     
  9. Decetch

    Decetch Thread Starter

    Joined:
    Aug 13, 2009
    Messages:
    82
    Hi JohnWill,

    Thanks for the assistance. The ping is returned on both computers with IP address and Computer name. I don't understand the bit about "both computers think they're the master browser" or how to correct it. As you can tell I don't understand a lot about this so I'm taking it a step at a time.

    By the way there were two instances in each computer that hadn't started a service. The XP computer was DNS Client and RPC and I forget which two they were in Win 7.

    Thanks
    John
     
  10. Decetch

    Decetch Thread Starter

    Joined:
    Aug 13, 2009
    Messages:
    82
    Hi JohnWill,

    I might have mis-lead you a bit with the last post. When I ping the Win 7 computer from the XP computer I get a return, with both IP address and name, also with firewall turned on or off. However, I get no response from the Win 7 computer when pinging the XP computer. I get "timed out" from the IP address and "host not found" from the computer name.
    Also, neither computer is visible in each others network. Hope I've explained that correctly. Thanks.

    John
     
  11. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Again, that suggests a firewall on the XP computer that is blocking the requests.
     
  12. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,184
    First Name:
    Terry
    If you are interested do a web search for Master Browser, and settle back to do some reading. :) Briefly, the computers on a network get together and draw straws (my terminology) to see who gets to be the master browser. All the losing browsers go back to their own computers and sulk and wait for the master browser to tell them all the names on the network. The master browser polls all the computers, creates a master list of names, and updates the other computers every 15 or 20 minutes.

    A firewall, as apparently you have on the XP, can prevent computers from "seeing" each other; hence multiple computers can think they are the master. For file sharing to work properly the network must have exactly one Master Browser.
     
  13. Decetch

    Decetch Thread Starter

    Joined:
    Aug 13, 2009
    Messages:
    82
    Hi TerryNet & JohnWill,

    Ok, here's where I'm at. The XP computer can ping the Win 7 computer with the firewalls on both computers turned on or off. The Win 7 computer CANNOT ping the XP computer with the firewalls on both computers turned on or off. So the question now, is this still a firewall problem?

    Thanks for your help.

    John
     
  14. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,184
    First Name:
    Terry
    It's not 100% that it's a firewall issue; don't have any data but would guess the probability is about 95%.

    Note in John's initial post in this thread:

    What firewall do, or did, you have on the XP?
     
  15. Decetch

    Decetch Thread Starter

    Joined:
    Aug 13, 2009
    Messages:
    82
    Hi TerryNet,

    Just realised I've made another error. Again you say? :) I forgot about my Antivirus Eset Nod 32/64. I turned the firewalls off in everything and I can now ping the XP computer from the Win 7 computer. So that's a start. The thing is what do I need to do now to configure it so it all works? Is it only the XP firewall I have to worry about? It's Windows firewall by the way.

    Thanks.

    John
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/955254

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice