Help setting NAS as FTP on home network

Status
This thread has been Locked and is not open to further replies. The original thread starter may use the Report button to request it be reopened but anyone else with a similar issue should start a New Thread. Watch our Welcome Guide to learn how to use this site.

meirionwyllt

Thread Starter
Joined
Jul 26, 2006
Messages
139
I have a wireless home network, and I have a Buffalo Linkstation Pro NAS connected by wire to my router. On the NAS I have a share, the contents of which I would like to be accessible via ftp from any PC anywhere.

I am complete FTP novice, but here's what I have done so far:

On the NAS's control panel I have allowed ftp support, set up access permissions, and given an user name/password, one set for read only and the other for read/write. I have also allowed ftp on my router's control panel (under Port Forwarding).

I am on static IPs (with PlusNET, my ISP) and I have registered my router's external IP with the DynDNS service so that my IP address can be used as a web address.

What else do I have to do to access the contents of the NAS via FTP? I don't want to have to install any third party software - I want to do it all with Windows/Internet Explorer if possible.

Please help,
Thanks.
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,726
What you describe should be sufficient.

One question. If you're on a static IP address, what are you doing with DynDNS?

Well, actually two questions, what ports did you forward in the router?
 

meirionwyllt

Thread Starter
Joined
Jul 26, 2006
Messages
139
Thanks for the reply.

Sorry I should have explained - it's the Static DNS service that I have signed up for, just to give my IP address a domain name that's easier to remember. DynDNS is just the name of the website that offers both Dynamic and Static DNSs as a service.

Your second question - I'm not sure which port, because in my router's (D-Link DSL-G604T) control panel, FTP is an option that I pick from a list of preset options that I can open ports for, just as I can do for things like POP3 or Bearshare. But I it doesn't show what port it actually is. I can only assume that it's port 21 but I can't be sure.

If I have in fact done all that's necessary to use FTP, how do I access it from the web browser? At the moment, if I type ftp://<IP address> into the browser, it just shows my router's control panel. How do I access the shares of the NAS? Do I have to specify Port 21 or something? What's the syntax that I need?

Thanks again.
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,726
If you're doing that locally within your network, you can't use the public IP address. If you're doing this remotely and getting the router's control panel, you need to disable remote administration on the router, which is a huge security hole! For local FTP access, you need to address the NAS IP address directly.

For accessing the ftp remotely, all you need is what you've specified.

One question, is the NAS setup on a static IP address? Are you sure the router's port forwarding is actually getting to the NAS IP address?
 

meirionwyllt

Thread Starter
Joined
Jul 26, 2006
Messages
139
Yeah sorry I meant to say that I was getting the router's control panel coming up when typing the public IP internally.

So, just to get this straight, is opening the right port all I have to do to get the contents of the share to appear in the browser?

Also, how do I check that I have the ftp port open?

Thanks
 

meirionwyllt

Thread Starter
Joined
Jul 26, 2006
Messages
139
When I say...

meirionwyllt said:
Also, how do I check that I have the ftp port open?
What I mean is, how do I double-check that the port is open? I have enabled the "FTP Port" in my router's control panel, but how do I know for sure. Is there a program/website that can check this for me?
 
Joined
Mar 12, 2002
Messages
5,520
Have you tryied typing in ftp://user: password@your ip: port number?

Disreguard the space between : and p if i put it in here in the post it turns out like
:p

Where user is the username you setup, password is the password your ip is your external ip and port number is the one you set up in the router...

Also if you used port 21 you may have to check to see if it is being blocked by your ISP ( check here http://www.canyouseeme.org/ )...
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,726
I have a dial-up account with a free service (limited hours/mo) for testing such things. Another method is to have a friend try to access the FTP server.
 
Joined
Sep 28, 2005
Messages
3,477
Add Port 22 (return side of the equation) to the forward and see what happens.
 

meirionwyllt

Thread Starter
Joined
Jul 26, 2006
Messages
139
Thank you all for your replies.

Jedi_Master - thanks for that website, I have now turned off the preset "FTP port forward" on my router and done it manually for port 21/22 of my NASs (static) IP address. When visiting the website you gave the link for, it says that port 21 is ok (but says that 22 isn't, even though I've also opened this on my router).

I have tried typing in the syntax you gave...

ftp://<user>:<password>@<my external IP>:21

...but to no avail.

Have I done all I need for my shared files to appear? When I type this into my browser, how does my router know to display the contents of a specific device on it's network?

Sorry if this is elementary stuff, but I would really like to learn about this.

Thanks
 
Joined
Mar 12, 2002
Messages
5,520
What's happening when you type that address in, blank screen, any errors?

Also what ftp server software does the NAS use, does it support Passive Mode?
 

meirionwyllt

Thread Starter
Joined
Jul 26, 2006
Messages
139
The only error message I get is just the standard one that Internet Explorer shows when it can't find a website "Internet Explorer cannot find this website", or words to that effect.

I don't know what ftp server the NAS uses, I guess it's their own inbuilt one. I will try to phone Buffalo this evening to find out more.

I will report back as soon as I have more info.
 
Joined
Mar 12, 2002
Messages
5,520
OK...

While waiting on Buffalo, try browsing through the FTP setup to see if there are any settings for Passive mode or PASV mode, and for a setting for listening port...

May have to set it up on a different port other that port 21...
 
Status
This thread has been Locked and is not open to further replies. The original thread starter may use the Report button to request it be reopened but anyone else with a similar issue should start a New Thread. Watch our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top