1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

HELP!!! USB ports stopped working!

Discussion in 'Hardware' started by Luna2308, Nov 10, 2008.

Thread Status:
Not open for further replies.
  1. Luna2308

    Luna2308 Thread Starter

    Joined:
    Nov 10, 2008
    Messages:
    3
    Hi,
    It would be great if anyone has an idea what kind of problem I am dealing with here.
    Two days ago, my USP ports just stopped working. I turned off my Toshiba Satellite A305-6829 in the evening, the next day I turned it back on, nothing.
    I tried to connect my mouse and two different external hard drives, their light is on, so there is power, but the devices are not recognized.
    In the device manager, it shows a yellow exclamation mark next to all the USB ports and under properties it says "Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)".
    I tried to uninstall the drivers and reinstall, it's still the same.
    Is there anything else I can do? Is it likely to be a hardware problem? The laptop is only 4 months old and everything else works fine.
    Thanks so much for any suggestions,
    Luna
     
  2. bigbear

    bigbear

    Joined:
    Apr 27, 2004
    Messages:
    4,719
    Try this fix by JohnWill

    Johnwill's solution

    Create a file with NOTEPAD containing the following lines and save it as FIX.REG
    -------------------------- Use text after this line --------------------------------
    REGEDIT4

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment]

    "DEVMGR_SHOW_NONPRESENT_DEVICES"="1"
    -------------------------- Use text before this line --------------------------------

    Double click on FIX.REG and say yes to the Merge Into Registry question.

    Unplug ALL USB devices.
    Open Device Manager.
    View, Show Hidden Devices.
    Uninstall all devices under USB Controllers.
    Uninstall all devices under Disk Drives that you know are not present.
    Uninstall all devices under Storage Volumes. Say no to any reboot prompts until you are finished. Also, if a Storage Volume doesn't uninstall, ignore it and move to the next one.
    If you have a yellow ? with unknown devices, uninstall all of the entries there as well.

    When this is done, reboot TWICE.

    Reconnect the USB devices and see if they're recognized properly.

    NOTE: If you have a USB keyboard and/or mouse, you'll have to modify the instructions and leave enough parts for those to function. I don't have one yet, so I haven't had time to modify the instructions.
    __________________
    Microsoft MVP - Shell/User
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/767832

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice