Help with my Pro Firewire 60GB Hard Drive 7200rpm

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

nroa9882

Thread Starter
Joined
Feb 12, 2005
Messages
3
I have an external harddrive that I bought about 3 years ago. Heres a picture of it When I went to access the files from it today my computer didn't register that it was there. It turns on, and kinda makes some noise like its working a bit...but my computer just won't register its existence. I tried unplugging it and plugging it back in, and restarting my computer and the drive. I tired to find new hardware but it didn't find it and the drive came with no software so I have nothing to try. I have a Dell inspirion 8000 laptop running XP. The device is connected by firewire connected to a card. I can't find a website from the company and I don't have the manual so I really have no idea what to try. I have a ton of stuff on there and I would hate the lose it, but I just want it to be able to work again. Any help or suggestions on what to try would be much appreciated. I'm glad I stumbled upon this website, it seems like an amazing site.
 
Joined
Jan 27, 2004
Messages
291
nroa9882 said:
I have an external harddrive that I bought about 3 years ago. Heres a picture of it When I went to access the files from it today my computer didn't register that it was there. It turns on, and kinda makes some noise like its working a bit...but my computer just won't register its existence. I tried unplugging it and plugging it back in, and restarting my computer and the drive. I tired to find new hardware but it didn't find it and the drive came with no software so I have nothing to try. I have a Dell inspirion 8000 laptop running XP. The device is connected by firewire connected to a card. I can't find a website from the company and I don't have the manual so I really have no idea what to try. I have a ton of stuff on there and I would hate the lose it, but I just want it to be able to work again. Any help or suggestions on what to try would be much appreciated. I'm glad I stumbled upon this website, it seems like an amazing site.
whats the model number search of the hardrive
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top