High ping/latency on one computer, not on others.

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

mnemos

Thread Starter
Joined
Oct 4, 2018
Messages
1
When I connect to a gameserver on my desktop PC I'll get on average about 120ms ping with fluctuations up to about 250.

If I take the exact same ethernet cable out and plug it into my laptop, I can play on the same gameserver at around 30-40ms ping.

Both devices are running Windows 10 x64, latest update. I've disabled the windows anti-virus, don't have any other installed, and nothing is using up my network resources in Task Manager.

I have no idea what is causing this. I initially thought it was malware but I've re-installed windows and the problem persists. A friend recommended I try a PCI-E network card, which I bought today but that hasn't solved the issue either.

I'm completely stumped. Any suggestions are welcome.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top